lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-13-2021, 02:49 PM   #1
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 4,629
Default A perplexing EZ-GO why won't this move?

I last drove my cart into my garage yesterday and all was fine. Today, after a charge, I jumped on the cart, turned on the key, hit reverse, heard the solenoid click....and nothing. NADA.....ZIP. No movement.

I turned the key off and on with no affect. I put the BMS into sleep mode and back on with no effect.

I then took my MM and began to check voltage readings. A buddy was helping me with hitting the go peddle.

So, I put the MM on the controller + and then the controller -, he hit the "gas" and WE GOT MOVEMENT!! The cart jumped so quickly I didn't get a voltage reading on the controller.

The controller gave it's normal green flashing light to say "all is good." I took the cart for a short ride and all is well.

Any thoughts on this mystery?
DaveTM is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-13-2021, 04:54 PM   #2
Bama Brad
Gone Wild
Mixed Breed
 
Join Date: Jul 2018
Location: Ramer, AL
Posts: 831
Default Re: A perplexing EZ-GO why won't this move?

Put a wrench on all the connections to make sure everything is good and tight. I had same problem with it VERY sporaticaly not working, it finally quit.it was a nut on the controller that was not loose, but was able to tighten it about 1/8-1/4 turn. Haven't had problem since. Never would have thought that it not being "tight" would shut cart down.
Bama Brad is offline   Reply With Quote
Old 04-13-2021, 05:17 PM   #3
Briboy
Gone Wild
 
Briboy's Avatar
Mixed Breed
 
Join Date: Sep 2020
Location: New Jersey
Posts: 225
Default Re: A perplexing EZ-GO why won't this move?

Just a though and my opinion... May not have been the "tightness" but rather a little oxidation between the terminal and post/nut.
Loosen all of the connections and spray some battery terminal cleaner on them. then wipe them off and give them a coating of battery terminal protector then retighten everything.
Briboy is offline   Reply With Quote
Old 04-14-2021, 05:38 AM   #4
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 4,629
Default Re: A perplexing EZ-GO why won't this move?

Could be oxidation. I checked the tightness of the main connections and some of the smaller ones by just grabbing the connector stud with my hand and seeing if I could move (rotate) them. None appeared loose.

But thanks for the idea of doing a good cleaning of the connections. Since I switched to lithium, terminal cleaning is a thing of the past....along with cleaning up any connections.

I'll give it a clean and see how it goes!
DaveTM is offline   Reply With Quote
Old 04-14-2021, 08:16 AM   #5
Bama Brad
Gone Wild
Mixed Breed
 
Join Date: Jul 2018
Location: Ramer, AL
Posts: 831
Default Re: A perplexing EZ-GO why won't this move?

Quote:
Originally Posted by DaveTM View Post
Could be oxidation. I checked the tightness of the main connections and some of the smaller ones by just grabbing the connector stud with my hand and seeing if I could move (rotate) them. None appeared loose.

But thanks for the idea of doing a good cleaning of the connections. Since I switched to lithium, terminal cleaning is a thing of the past....along with cleaning up any connections.

I'll give it a clean and see how it goes!
I did the same....all were tight to touch. Wasn't until I actually put a wrench on them that I discovered it. Wrench only turned slightly, didn't think it was the problem, but it was. Cart took off and hasn't stopped since.
Bama Brad is offline   Reply With Quote
Old 04-15-2021, 06:47 AM   #6
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 4,629
Default Re: A perplexing EZ-GO why won't this move?

Quote:
Originally Posted by Bama Brad View Post
I did the same....all were tight to touch. Wasn't until I actually put a wrench on them that I discovered it. Wrench only turned slightly, didn't think it was the problem, but it was. Cart took off and hasn't stopped since.
Thanks Brad...and all others. It's gonna be cool and rainy today.....good day to go to the garage (heated) and check my connections!!
DaveTM is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
97 CC 48v will not move f\r. Electric Club Car
Won't move Electric EZGO
G29 will not move Electric Yamaha
04 ds will not move Electric Club Car
1996 Series DS 48V won't move on ground, wheels barely move on jacks Electric Club Car


All times are GMT -5. The time now is 01:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.