lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Melex


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-10-2008, 04:36 PM   #1
scatterbolts
Not Yet Wild
 
Join Date: Mar 2008
Posts: 4
Default Melex 36 Volt Cart only goes at slow speed

I have a 1993 Melex cart. When you press on the acelerator it starts to move then stops. If you are very slow and easy on it it will begin to move slowly. On a flat paved surface you can eventually get it going fast but it kicks out at any incline. If you jack up the rear tires so they are off the ground it seems to work fine. All batteries are about 3 years old all show 6.5+volts. It does the same thing in forward or reverse. Any ideas?
scatterbolts is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Melex


Thread Tools
Display Modes


Similar Threads
Thread Forum
48 Volt Melex Cart Golf Carts and Parts
Super Speed Your Cart..... Gas Club Car
Touchy Gas Pedal At Slow Speed Gas EZGO
High Speed cart gears Gas Club Car
Ezgo speed cart for sale Golf Carts and Parts


All times are GMT -5. The time now is 07:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.