lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-28-2015, 11:36 PM   #1
peatsaman
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2015
Location: iowa
Posts: 2
Default 1988 ez-go gets up to speed then stops running

Hi, I got a 88 ez-go I have been working on. First it wasn't getting gas so I got that figured out replaced fuel pump. It fired right up and ran great for about 15 20 seconds then it would slow to almost a stop, then rev back up and take off again. I've replaced fuel filter, emptied the gas and refilled, took off carb and cleaned (had a lot of crap in the bowl). Could the carb be junk? Or maybe an electrical issue? Any ideas
Thanks
Rick
peatsaman is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-29-2015, 12:06 AM   #2
cart around
Test before replacing
E-Z-GO
 
Join Date: Aug 2013
Location: Ohio side of the Pennsylvania border.
Posts: 3,313
Default Re: 1988 ez-go gets up to speed then stops running

It sounds like you have a fuel delivery problem, not an electrical issue.

It surges, runs out of gas, and then surges again. I would say clean the fuel pump, but you already replaced it with a new one.

Give the carb another good cleaning, and then do some research on changing the crankshaft seals. You won't be too thrilled about that.

We could also use some more detail on how long you have had the cart, what work has been done to it, and if it has ever run correctly while in your possession.
cart around is online now   Reply With Quote
Old 04-29-2015, 12:16 AM   #3
peatsaman
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2015
Location: iowa
Posts: 2
Default Re: 1988 ez-go gets up to speed then stops running

I've had it about 6 years or so. It's been sitting the last 2-3 years. Before that I used it quite a bit golfing. It ran fine.
Decided to get back into golfing so I've been trying to get it running.
This is all I've done to it, it's always ran good besides a spark plug a couple times.
I'll take another look at the carburetor tomorrow.
peatsaman is offline   Reply With Quote
Old 04-29-2015, 06:55 AM   #4
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,190
Default Re: 1988 ez-go gets up to speed then stops running

If the vent line on the carburetor was locked you would see the same symptoms. There should be a clear plastic line from the top of the carburetor that goes nowhere. This is to let air in as the fuel gets sucked out of the bowl. Check to see if it is blocked, if it is missing look for the nipple on the top of the carburetor and see if that is blocked.

Dave
Dave Box is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2010 precedent stops running at speed Electric Club Car
Stops Running Electric Club Car
'84 cc stops running after 5 min Gas Club Car
G16 stops running Gas Yamaha
stops running Gas EZGO


All times are GMT -5. The time now is 06:43 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.