lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-20-2008, 10:38 PM   #1
bsrock
Not Yet Wild
 
Join Date: May 2008
Posts: 5
Question Columbia par car 96 prob

Ok so all weekend my cart battery kept going low and died on me a few times I looked under the hood and where the switch was {when you push the gas the trigger switch} there was a wire loose so I reconnected it and the battery was charging again but **** did I lose power I usually pull it up into my toy hauler no prob but with the wire connected would not even make it half way up disconnected the wire and boom right up could this be because of the load with the battery being low? or what Im lost
bsrock is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas golf carts > Gas Columbia ParCar


Thread Tools
Display Modes


Similar Threads
Thread Forum
Speed controller prob. Electric Club Car
Par Car..??? Columbia.. Electric Club Car
G9 Changed motor mounts-found another prob. Gas Yamaha
1993 Gas Clubcar CarryAll Electrical Prob??? Gas Club Car
columbia par car solenoid??- HELP!! Columbia ParCar


All times are GMT -5. The time now is 10:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.