lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-14-2008, 04:06 PM   #1
cjcustoms
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2008
Location: rochester,mn
Posts: 31
Default G2 runs great but load surge

I got a 1982 yamaha g2 at first picked it up and it didnt run. I replaced alot of tune up parts. It runs great. I put a new drive belt on it.It runs great but when you any weight like two people or a small hill or just stop and hammer on it the motor kills and the belt sqeeks.LOOKING FOR ADVISE
cjcustoms is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-17-2008, 09:59 AM   #2
curtisjade1
Not Yet Wild
 
curtisjade1's Avatar
Yamaha
 
Join Date: Aug 2008
Location: Belleville,Ontario,Canada
Posts: 7
Default Re: G2 runs great but load surge

you may need to get a torque spring that would fix the problem but it should still run fine if your only putting two people on it most carts can handle that with no problems
curtisjade1 is offline   Reply With Quote
Old 09-17-2008, 10:06 AM   #3
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,377
Default Re: G2 runs great but load surge

Sounds like the bushing in the rear clutch is dry and locking up. Try greasing the rear clutch assembly: grease fitting on the triangle shaped part of inner sheave. Only give it no more than two pumps of grease if totally dry. Any more and it will seap out onto the shaft and then the belt making a mess.

p.s. spring/spacer torque kit would also be a good investment.

spriddle is offline   Reply With Quote
Old 09-23-2008, 10:11 PM   #4
cjcustoms
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2008
Location: rochester,mn
Posts: 31
Default Re: G2 runs great but load surge

thanks guys i will have to try the grease thing thanks alot
cjcustoms is offline   Reply With Quote
Old 09-24-2008, 09:00 PM   #5
cjcustoms
Not Yet Wild
E-Z-GO
 
Join Date: Mar 2008
Location: rochester,mn
Posts: 31
Default Re: G2 runs great but load surge

could anyone send a pic of that greese fitting
cjcustoms is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
1991 2 Stroke that runs great, once, then wont restart Gas EZGO
Power surge on '96 G19 Electric Yamaha
1994 Ezgo electric runs great in reverse but does not forward Electric EZGO
97 g16 off and on power surge Electric Yamaha
98 48V JERKS under Load Electric Club Car


All times are GMT -5. The time now is 02:02 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.