lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-16-2011, 10:22 PM   #1
fingerpicker
Getting Wild
 
Join Date: Apr 2011
Posts: 107
Default 1982 Ez Go roaring while driving

Hello all,
I've got a 1982 EzGo and have been noticing lately there's a bit of a roaring sound when picking up speed. It's kind of a hard to describe. It almost sounds like a scrubbing like sound when the tire pressures are out of sync. I checked the pressures and they were out of sync. I fixed them, but the problem is still there. The cart seems to be driving alright. The alignment is a little out if I let go of the wheel, but I figured it would be with the age. When I look at it head on it doesn't seem to be off with the front end compared to the back end, but again tough to really tell. I hope maybe somebody has been through something similar to this.
fingerpicker is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-17-2011, 07:31 AM   #2
shadowman
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1982 Ez Go roaring while driving

2 things come to mind..............1st signs of a clutch going bad or the rearend trying to tell you something..........have you ever changed the rearend lube? it might be wroth taking a peek you might be able to nip something in the bud............................
shadowman is offline   Reply With Quote
Old 05-17-2011, 08:34 AM   #3
fingerpicker
Getting Wild
 
Join Date: Apr 2011
Posts: 107
Default Re: 1982 Ez Go roaring while driving

No , I,m not sure about how to change the rear end lube. I am kind of new to the carts. I hope it's not something too complicated. Are you talking about inside transmission between back axle. I looked back there and noticed a plug it looks like. It looks a little moist around the bolts, but not real wet. Maybe it's some kind of potential leak, but I haven't noticed any leaking coming from it. I sure hope it's not the clutch. I just got the cart running and was thinking I had a driven clutch problem. I got a new belt and it seems like it's been running fine, excpet for scrubbing like sounds when going faster.
fingerpicker is offline   Reply With Quote
Old 05-17-2011, 09:14 AM   #4
shadowman
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1982 Ez Go roaring while driving

just like a car rearend your cart has one ......there is lube in the pumpkin and if it gets to low it will start making a roaring noise...........................
shadowman is offline   Reply With Quote
Old 05-17-2011, 06:00 PM   #5
Dave Box
Respect the Cart
 
Dave Box's Avatar
E-Z-GO
 
Join Date: May 2010
Location: Rocky Mount, Virginia
Posts: 2,189
Default Re: 1982 Ez Go roaring while driving

I would get the back axle on stands and get someone to hold the throttle whilst you listen and see if you can pinpoint the noise. This will also rule out tire noise. If you want to change your axle oil and I recommend that you do, here is a nice article.
http://www.buggiesgonewild.com/ezgo-...a-rearend.html
Good Luck
Dave
Dave Box is offline   Reply With Quote
Old 05-17-2011, 07:10 PM   #6
fingerpicker
Getting Wild
 
Join Date: Apr 2011
Posts: 107
Default Re: 1982 Ez Go roaring while driving

I'm going to change it this weekend. thank you so much for the info on it and the materials used on it. This is the last $500 cart I will buy lol. I have been changing all kinds of things. It seems like it never ends. I just got a deal on a top for $25 with the back bars, but the top was a different one. It' meant for like a newer one like a 2007 and mine's an 82, so the bars at the back of the seats don't bolt right with the seat rest bars. I guess i'll have to look for a new seat rest and mounting brackets.That's my next task. It does seems to be running alright though for a cheap cart.
fingerpicker is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ Go Walks when driving Electric EZGO
Help G9 driving me crazy Gas Yamaha
2004 E Z Go txt roaring noise Electric EZGO
G1 Driving me mad! Gas Yamaha


All times are GMT -5. The time now is 04:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.