lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-19-2008, 03:03 PM   #1
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default wont run with airbox

I have a G2 that wont hardly run at all with the airbox installed, low speed ok,at w.o.t. just bogs and stalls. With or without a filter has no change. Even with a k&n cone filter right on the carb it wont run. With nothing installed it runs great at all throttle positions. What should I look at to fix this?

Thanks
T M C
cupcake is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-19-2008, 07:41 PM   #2
hotwatermusic
Gone Wild
 
hotwatermusic's Avatar
 
Join Date: Dec 2007
Location: lake county FL
Posts: 327
Default Re: wont run with airbox

sounds like a clogged main jet. try cleaning the carb VERY VERY good. TWICE
hotwatermusic is offline   Reply With Quote
Old 02-19-2008, 07:42 PM   #3
TheNewGuy
Admin/Moderator
 
TheNewGuy's Avatar
Yamaha
 
Join Date: Dec 2006
Location: Ohio
Posts: 17,965
Default Re: wont run with airbox

Sounds to me like the main carb jet is too big.

TheNewGuy is offline   Reply With Quote
Old 02-19-2008, 07:59 PM   #4
groundpounder
Gone Wild
 
groundpounder's Avatar
Yamaha
 
Join Date: Sep 2007
Location: maine
Posts: 3,352
Default Re: wont run with airbox

sounds like the carb joint may have a crack in it sucking air
groundpounder is offline   Reply With Quote
Old 02-19-2008, 08:06 PM   #5
smallblock450sl
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,854
Default Re: wont run with airbox

Quote:
Originally Posted by cupcake View Post
I have a G2 that wont hardly run at all with the airbox installed, low speed ok,at w.o.t. just bogs and stalls. With or without a filter has no change. Even with a k&n cone filter right on the carb it wont run. With nothing installed it runs great at all throttle positions. What should I look at to fix this?

Thanks
T M C
Are you saying....With the "stock" complete air box assy, it runs on the flat, But any "power pull", it "dogs out" ? Or are saying the K & N filter set up is causing the problem ? Please give us more details. I'm shure several of us have had the same problem.......When you say with nothing "installed", It tells me your factory air box assy is not "sealed right"! Keep us posted Dave
smallblock450sl is offline   Reply With Quote
Old 02-19-2008, 11:42 PM   #6
cupcake
Not Yet Wild
 
cupcake's Avatar
 
Join Date: Feb 2008
Posts: 16
Default Re: wont run with airbox

ok maybe this will help.
With the factory air box installed it wont run above idle.

With the k&n installed it wont run above idle.

Wont even "run on the flat" bogs out and stalls when any throttle is applied above an idle but with no airfilter at all runs great.

Im sure the main jet is factory never been changed.

I will open up the carb and look and clean and check the manifold for crack. I mean for cracks. Thanks
cupcake is offline   Reply With Quote
Old 02-20-2008, 06:41 PM   #7
hotwatermusic
Gone Wild
 
hotwatermusic's Avatar
 
Join Date: Dec 2007
Location: lake county FL
Posts: 327
Default Re: wont run with airbox

nice avatar cupcake
hotwatermusic is offline   Reply With Quote
Old 02-20-2008, 07:27 PM   #8
smallblock450sl
Sometime's............
 
smallblock450sl's Avatar
Yamaha
 
Join Date: Oct 2007
Location: Tacoma Washington
Posts: 11,854
Default Re: wont run with airbox

Quote:
Originally Posted by cupcake View Post
ok maybe this will help.
With the factory air box installed it wont run above idle.

With the k&n installed it wont run above idle.

Wont even "run on the flat" bogs out and stalls when any throttle is applied above an idle but with no airfilter at all runs great.

Im sure the main jet is factory never been changed.

I will open up the carb and look and clean and check the manifold for crack. I mean for cracks. Thanks
If you want to keep the "stock' air box assy..Make shure there are no holes or cracks in the lower air box case, make shure all 4 air box straps are in good shape (plyable and "pull" the lid down onto the bottom case), that all the parts are there, that that the "lid" is not "worped", that the "seal" in the lid is nice and flat (so it can seal) and that no one before has used pop rivets/screws ect to replace the "strap" tabs. If you already have a K & N filter...use it. Just ask Hotwatermusic how to "enlarge" the main jet. More air...Needs more fuel. Good luck Dave
smallblock450sl is offline   Reply With Quote
Old 02-20-2008, 10:54 PM   #9
hotwatermusic
Gone Wild
 
hotwatermusic's Avatar
 
Join Date: Dec 2007
Location: lake county FL
Posts: 327
Default Re: wont run with airbox

cupcake there are alot of posts on how to enlarge the main jet located in the carbs "bowl'" located at the bottom of the carb. you can take it(the jet) out and just make sure it is not clogged and used the factory airbox, but like dave said if you have a K&N utilize it. pick up some torch tip cleaning bits form a sears or something. all i did was found the size that fit it stock and went one size up and it worked great. you might have to play with the air/fuel ratio on the carb but it was very easy.
hotwatermusic is offline   Reply With Quote
Old 02-21-2008, 09:53 AM   #10
spriddle
Admin
 
spriddle's Avatar
Yamaha
 
Join Date: Dec 2006
Location: TN
Posts: 101,771
Default Re: wont run with airbox

Sounds like the plastic spacer between the carb. and intake is cracked.

spriddle is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart wont start Gas EZGO
93 36V cart wont move Electric Club Car
club car wont go Electric Club Car
she wont go so EZ Electric EZGO
Rear clutch wont engage Big Block Talk!


All times are GMT -5. The time now is 07:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.