lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-08-2021, 06:22 AM   #11
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 4,811
Default Re: Change from Chinese BMS to Zeva

Apparently, from this technical manual :https://www.masterpiece.dk/uploadetf..._Manual_23.pdf

You need to check your model number. On page 2 of the link, if you have an "A" in your Product Number, the charger is for Lead Acid Batteries. But, it's unclear to me if the other codes are for Lithium. I'd suggest you contact the manufacturer for clarity.

On the Canbus sensor, if you have it....use it.
DaveTM is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-08-2021, 07:50 AM   #12
a_machinist
Not Yet Wild
 
Join Date: Aug 2017
Posts: 28
Default Re: Change from Chinese BMS to Zeva

I think at this point I'd rather buy the right charger. Any suggestions?
a_machinist is offline   Reply With Quote
Old 08-21-2021, 04:03 PM   #13
a_machinist
Not Yet Wild
 
Join Date: Aug 2017
Posts: 28
Default Re: Change from Chinese BMS to Zeva

Ok so I added in the charger relay and I have about 49v at the pack and I'm only showing 32.7v after the gigavac. And now I have no movement or solinoid clicking. Also doesn't seem to be charging. Any ideas?
a_machinist is offline   Reply With Quote
Old 08-25-2021, 02:56 PM   #14
a_machinist
Not Yet Wild
 
Join Date: Aug 2017
Posts: 28
Default Re: Change from Chinese BMS to Zeva

Bump, any help?
a_machinist is offline   Reply With Quote
Old 08-25-2021, 03:21 PM   #15
Ronno6
Gone Wild
 
Join Date: Jan 2013
Posts: 193
Default Re: Change from Chinese BMS to Zeva

Way outa my league....I'm not ignoring you, just can't help....
Ronno6 is offline   Reply With Quote
Old 08-25-2021, 04:43 PM   #16
DaveTM
Gone Wild
 
DaveTM's Avatar
 
Join Date: Oct 2012
Location: Southwestern Pa.
Posts: 4,811
Default Re: Change from Chinese BMS to Zeva

Quote:
Originally Posted by a_machinist View Post
Ok so I added in the charger relay and I have about 49v at the pack and I'm only showing 32.7v after the gigavac. And now I have no movement or solinoid clicking. Also doesn't seem to be charging. Any ideas?
Ok.....precisely what charger are you using?

Did the charger kick off at 49V?

Can you post a pic of your wiring?

Also......with a 14 module leaf pack you are running a 48V system? Yes?
DaveTM is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Zeva parts layout, what would you change? All things Lithium
Chinese GY6 CV carb Clone Engine Swaps
Need Help with Chinese cart Electric golf carts
chinese shocks? Lifted Golf Carts


All times are GMT -5. The time now is 10:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.