lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-10-2017, 01:38 PM   #1
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 563
Default CC Precedent throwing "main welded" code but cart still runs....

I have a 2008 CC Precedent that's throwing the "main welded" fault code but the cart still runs albeit it runs very slow "9mph". I've already changed out the speed sensor and that hasn't helped. I didn't think it was possible for a cart to run with the solenoid welded closed. Any suggestions??
twilliams81 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-10-2017, 01:43 PM   #2
mrgolf
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,881
Default Re: CC Precedent throwing "main welded" code but cart still runs....

The way I understand your solenoid welded will cause cart to go into limp mode. You likely did not need to change the speed sensor. Should have been solenoid.
mrgolf is offline   Reply With Quote
Old 07-10-2017, 02:28 PM   #3
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 563
Default Re: CC Precedent throwing "main welded" code but cart still runs....

10-4 I'll try that and if it fixes it I'll put the old sensor back on... Thanks buddy I didn't realize that Precedents had a limp mode.
twilliams81 is offline   Reply With Quote
Old 07-11-2017, 12:52 PM   #4
twilliams81
Gone Wild
 
Join Date: Aug 2016
Posts: 563
Default Re: CC Precedent throwing "main welded" code but cart still runs....

Good news! Replaced the solenoid and it runs great and I put the old speed sensor back on and still runs great! Thanks for the info again! This site rocks!
twilliams81 is offline   Reply With Quote
Old 07-11-2017, 01:32 PM   #5
mrgolf
Old Sky Soldier
 
mrgolf's Avatar
Club Car
 
Join Date: Dec 2011
Location: Kentucky
Posts: 3,881
Default Re: CC Precedent throwing "main welded" code but cart still runs....

Good to hear. Everything I told you I've learned reading the site.
mrgolf is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO PDS "welded solenoid" code Electric EZGO
Main welded code still Electric Club Car
2000 EZGO TXT rebuild - Code name "Vader" Members Rides
Help- "Main Drop Out" on curtis controller Electric EZGO
2008 prec "Main welded" slow speed Electric Club Car


All times are GMT -5. The time now is 03:40 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.