lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-03-2020, 01:43 PM   #1
gandl2123@gmail.com
Not Yet Wild
 
Join Date: Aug 2020
Posts: 2
Default 2006 MPT 1200 (MCI?) No Spark, tried everything...

Hello and thanks in advance. Trying to get an ole cart going for my father in law who is disabled and needs it for running back and forth to neighbors and friends. You know, to enjoy life.

Got this 2006 MPT 1200 for $1000 dollars and it is in great shape with recently rebuilt engine that was running one day, parked. Then would not move the next day.

It has NO SPARK. We have ran down all of the lines, all of the grounds and checked everything...there are 3 coils and multiple parts have been tossed at it. The voltage regulator, coil, pulsar coil, pick up coil by regulator have all been swapped out for ones we think/thought are good. We still can get no spark. Push the gas, she turns over like she should but no spark what so every.

I have a new pulser coil and electrical coil on order but not sure that is theproblem. The fan is connected to the flywheel as we test things...there is the ?reluctor" ring thingy that goes around as we crank and the pulsor gap seems to be normal...just no spark at all.

I would appreciate any help that you could toss my way so that we can get this cart up and going again. Tks

Frustrated in Augusta, GA (where it was built) and son is a mechanic there and we have done everything that we can think of. So, feather in your cap if you can knock this out of the park. Tks

Greg
gandl2123@gmail.com is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-03-2020, 02:09 PM   #2
big mule
Gone Wild
 
big mule's Avatar
E-Z-GO
 
Join Date: Aug 2009
Location: Santuck,Al
Posts: 1,734
Default Re: 2006 MPT 1200 (MCI?) No Spark, tried everything...

Have you tried a "known working" ignitor yet?The MCI is very easy to swap,just unplug the one in the cart,leave it bolted in & plug the harness into another to test .
big mule is offline   Reply With Quote
Old 08-03-2020, 04:02 PM   #3
trig123
Gone Wild
 
trig123's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: Out there somewhere
Posts: 2,211
Default Re: 2006 MPT 1200 (MCI?) No Spark, tried everything...

For those if us who work on these carts like big mule and me we keep spare ignition parts for testing only.

The pulser coil is an easy test. Remove the wire connector that heads down under fan. Set a DVOM to 20 AC volts and connect the red and black lead of that meter to those two wires and spin over. It should generate at least 1/2 volt when doing this. They just don't go bad much.

I wouldn't be ordering parts until I knew for sure what I needed. Those ignitors are high dollar and the only ones I would use would be OEM .

Other ignition parts the same. OEM only and stay away from those on ebay and amazon.
I am sorry to have to tell you that many of these cheap ones you see out there are trash and a total waste of your money. My 2 cents

You didn't try to crank this cart while the battery was on charge did you ?
trig123 is offline   Reply With Quote
Reply

Tags
mpt 1200, no spark
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2006 mci motor no spark at all Gas EZGO
Ego workhorse 1200 Gas EZGO
88 marathon new 79 dodge coil little spark then no spark? Gas EZGO
Could this be an MPT 1200? Gas EZGO
1999 workhorse 1200 or 2006 workhorse 800, which one? Gas EZGO


All times are GMT -5. The time now is 07:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.