lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-03-2009, 08:32 PM   #1
LongbeardExpress
Getting Wild
 
LongbeardExpress's Avatar
E-Z-GO
 
Join Date: Feb 2009
Location: Lexington, SC
Posts: 140
Default Broken shackle mount

Anyone else ever had a problem with the weld breaking on a rear shackle mount? I was putting the rear lift kit on my 97 ezgo and found one side was broken and had been for a while. Just wondering if I should cut the other one off too and re-enforce both of them or just reinstall the broken one.
LongbeardExpress is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-03-2009, 09:31 PM   #2
mikesmotortoys
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Broken shackle mount

It's not uncommon for that to happen on a well 'used' cart. We see one or two a year. Clean up the welds and weld back. No reason to cut the other one off, unless it has been poorly repaired in the past.

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Old 03-04-2009, 08:01 PM   #3
LongbeardExpress
Getting Wild
 
LongbeardExpress's Avatar
E-Z-GO
 
Join Date: Feb 2009
Location: Lexington, SC
Posts: 140
Default Re: Broken shackle mount

Thanks Mike. Other weld is factory. Didnt see any breaks so Im gonna let sleepin dogs lie.
LongbeardExpress is offline   Reply With Quote
Old 03-04-2009, 08:39 PM   #4
mikesmotortoys
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Broken shackle mount

Quote:
Originally Posted by LongbeardExpress View Post
Thanks Mike. Other weld is factory. Didnt see any breaks so Im gonna let sleepin dogs lie.

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Help My carts broken!!!! Gas Yamaha
Broken Battery Cable Electric EZGO
Fixing broken terminals? Electric EZGO
Broken parts Gas EZGO


All times are GMT -5. The time now is 08:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.