lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-14-2013, 08:05 AM   #1
lead foot larry
Not Yet Wild
 
Join Date: May 2013
Posts: 21
Default 1986 EZGO no spark

Hello,
I just picked up my 1st golf cart. The guy says its a 1986. It's a 2 cycle model oil injection with a dump box on the back. Kinda cool little cart. He says it ran fine when they parked it last fall but now it won't start. It doesn't appear to have any spark. It doesn't look like they took the best care of it so I'm wondering if it may be as simple as something getting moisture in it. It has an external coil, is there a way to check that out before I spring for a new one ? Any ideas as to where to start trouble shooting it ? And finally what model would this be ? It's got like a little box on the back similar to a pickup truck and external headlights that are on brackets.
Thanks for your help.
lead foot larry is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-14-2013, 08:50 AM   #2
RussellGehrer
Not Yet Wild
 
Join Date: May 2013
Posts: 26
Default Re: 1986 EZGO no spark

Have you tried a new spark plug. I would try that before you go putting a coil on. Plug is very cheap and if cart wasn't maintained it could probably use a new one anyways.
RussellGehrer is offline   Reply With Quote
Old 05-14-2013, 09:26 AM   #3
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: 1986 EZGO no spark

You should be able to have your coil tested at Autozone. If it's bad I would use a regular 12V automotive coil. Some people don't like that but I've had absolutely no problems with it. It could also be your ignitor, pulsar, or as Russell said, your sparkplug can be fouled. Check the plug by removing it, hook it up to the wire, and lay the metal part of the plug against bare metal on the engine block. Crank the engine over (Wheels on stands) and you should get a good blue spark.

If you have a good coil and your plug looks nice and clean, try a new plug wire. If still nothing you might have a bad igniter. This is expensive and there's no way to test it besides putting it on another cart that you know runs. There's a great work around for this though. You switch it to an HEI module for a GM which costs about $15. This is down the road though. Check your plug, coil, and wire. And if you run into anything that you don't get or doesn't seem right, stop right there and ask questions. We are here and we can help.

As far as the oil injector, mix your fuel at 125:1 and get rid of that thing. Make sure and plug the hole in the intake where the line ran to. If it fails you won't know until you've burnt up your engine.

As far as model, we need the numbers. There should be a plate somewhere up front under the dash I believe.
Heliarc is offline   Reply With Quote
Old 05-25-2013, 05:33 PM   #4
lead foot larry
Not Yet Wild
 
Join Date: May 2013
Posts: 21
Default Re: 1986 EZGO no spark

ok now my daughter is bugging me about this so i really gotta get going on it. the sn is a13057 and the man num is gt886. any idea what year and make ? any info would be very helpful. thanks
lead foot larry is offline   Reply With Quote
Old 05-25-2013, 05:54 PM   #5
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: 1986 EZGO no spark

Gas GXT800 Truck 1986 according to a serial number search.

Looks something like this perhaps?

Heliarc is offline   Reply With Quote
Old 05-25-2013, 07:26 PM   #6
lead foot larry
Not Yet Wild
 
Join Date: May 2013
Posts: 21
Default Re: 1986 EZGO no spark

yeah it looks like that only mine is beat up !
lead foot larry is offline   Reply With Quote
Old 05-25-2013, 11:31 PM   #7
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: 1986 EZGO no spark

Right on. If you have a shop around make sure you get the crank seals and intake checked for leaks once you get it running. A small engine repair place should be able to handle it. Old two strokes you always check those seals. If they're shot the engine runs lean and you burn it up. Same for the intake boot and anywhere else it can suck air.

I'm not sure about this, and I hope someone will correct me if I'm wrong, but I think that's the same engine as an EZ-GO cart of the same year. If you get everything tested and it comes down to the one part you can't test which I think is the ignitor, you're better off doing the HEI conversion.
Heliarc is offline   Reply With Quote
Old 05-29-2013, 07:49 PM   #8
lead foot larry
Not Yet Wild
 
Join Date: May 2013
Posts: 21
Default Re: 1986 EZGO no spark

Ok got a new plug an plug wire, still no spark ! Our Auto Zone did 't have clue how to test the coil. You guys spoke of using a auto coil, what year ect. should i be looking for ? Thanks again for your help.
lead foot larry is offline   Reply With Quote
Old 05-29-2013, 09:24 PM   #9
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: 1986 EZGO no spark

I'm thinking because it's from a golf cart they're not going to know the values they should be looking for . Most of these guys that work autozone are hand picked from the finest of convenience stores and have little actual knowledge of what they're selling. Perhaps call an ATV/snowmobile shop. I'd bet they can check it out for you. But if you do end up going the auto coil route(which some people disagree with), the coil on my 88 Marathon is just some random thing that was in my shop. Pretty much as long as it runs on 12 volts it can be used. I had three different coils on mine just to see if there was any difference but it didn't seem to matter at all. Of course this was after I changed over to HEI ignition.

Personally, if someone brought me this cart, I'd suggest the HEI mod at this point. It's so simple to do and replaces cart specific parts with automotive parts that are cheap and easily available. If you can wire a car stereo you can do this with one arm behind your back. Before I saw about it I was facing over $110 for the igniter, which you can't test except for putting it into someone elses cart that you know runs, and I wouldn't have known if it was the problem or not. I did the HEI thing with junkyard parts and the cart still runs great years later. Not to mention after the HEI mod, if your spark fails again the components can all be tested at any auto parts store with a multimeter.

http://www.buggiesgonewild.com/gas-e...coil-test.html <----
Heliarc is offline   Reply With Quote
Old 05-30-2013, 07:51 AM   #10
lead foot larry
Not Yet Wild
 
Join Date: May 2013
Posts: 21
Default Re: 1986 EZGO no spark

Keeping in mind if this doesn't work I will switch the whole thing over to a HEI, could you please give me a year and make of a auto coil that would work and I'll just go to auto-Zone and grab one
lead foot larry is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1980 ezgo gas SPARK/NO SPARK Gas EZGO
1986 EZGO Gas Golf Carts and Parts
1986 gas ezgo need help Gas EZGO
1986 Yamaha G2/ NO SPARK Gas Yamaha
1986 Yamaha G2/ No spark Test Post


All times are GMT -5. The time now is 11:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.