lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-10-2022, 10:44 AM   #1
Bonds25
Not Yet Wild
 
Join Date: May 2020
Posts: 8
Default RXV w/ no power, unable to move w/ Eco Battery

Hey everyone.....last night I was driving my RXV home when all of a sudden the power started to cut in and out. I installed the Eco Battery 48V 72ah battery at the beginning of August and have had no problems to date. The Eco Battery dash display started flickering and then went blank. My cart then locked up, unable to move. I had 35% battery left. Thankfully I was close to home so I was able to get my trailer down to grab it. I also was right by the FD Department so they saw me struggling to get it in the trailer so we lifted the back end up to load it. This happened at dark so I had no time to do anything with it at home. This morning I plugged it in and the dash lit up and the Eco Battery charger started to cycle on and off. Thatís all the info I have until I get home later today. Does anyone have any ideas? Maybe a short somewhere is what Iím thinking but who knows??? I do know I need to get it out of my trailer and into my garage. Would it hurt anything if I left it plugged in to at least get the power somewhat back on to hopefully get it in neutral to roll it off the trailer? If I canít get it in neutral, how can I get the wheels to unlock to be able to move it? Any thoughts or suggestions would be much appreciated. Thanks!
Bonds25 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-10-2022, 11:14 AM   #2
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,698
Default Re: RXV w/ no power, unable to move w/ Eco Battery

Sounds like the BMS shut down. Contact Eco to find out how to try to reset it. (or maybe someone here will know how to do that) I think the brake requires power to release unless you manually release it. There are threads in the EZGO section on how to release the brake.
Volt_Ampere is offline   Reply With Quote
Old 10-10-2022, 11:26 AM   #3
SBIRD!
Gone Wild
 
SBIRD!'s Avatar
E-Z-GO
 
Join Date: Aug 2016
Location: Lickin' County, Ohio
Posts: 259
Default Re: RXV w/ no power, unable to move w/ Eco Battery

Try the tow switch first, then try switching the plugs under the controller cover(the instructions are there). With no power the only other option is to remove the brake. Unplug it and remove the 3 10mm bolts.
SBIRD! is offline   Reply With Quote
Old 10-10-2022, 11:48 AM   #4
Volt_Ampere
Gone Wild
Yamaha
 
Join Date: May 2012
Location: Rio Verde, Az
Posts: 5,698
Default Re: RXV w/ no power, unable to move w/ Eco Battery

Measure your battery voltage to see if it's shut down. If it is, you can't power the brake even in TOW mode. Find out how to reset the BMS. Often, it's reset by hooking up the charger but I don't know anything specific about ECO batteries.
Volt_Ampere is offline   Reply With Quote
Old 10-10-2022, 12:11 PM   #5
Bonds25
Not Yet Wild
 
Join Date: May 2020
Posts: 8
Default Re: RXV w/ no power, unable to move w/ Eco Battery

Thanks for all the replies. It wouldn't do anything in Tow mode when I tried last night. I'll have to try again tonight when I get home. Any shots in the dark on what would cause this to just shut down like it did?
Bonds25 is offline   Reply With Quote
Old 10-10-2022, 02:39 PM   #6
wingnut2000
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 465
Default Re: RXV w/ no power, unable to move w/ Eco Battery

Mine did this with a HSKY Big Battery not too long ago and I checked all my wiring over several times and I didnt think the battery went dead but it did because last several times riding it just hadnt been charged afterwards. It wouldnt even go into neutral to push home by switching plugs around until about the 20th time switching plugs back and to then it finally went in to neutral and i had it towed home. Hooked to charger and all is good now.
wingnut2000 is offline   Reply With Quote
Old 11-02-2022, 11:09 PM   #7
PuttPutt
Gone Wild
 
PuttPutt's Avatar
E-Z-GO
 
Join Date: Jan 2012
Location: Chico, California
Posts: 478
Default Re: RXV w/ no power, unable to move w/ Eco Battery

My neighbor had a similar problem but for him when he plugged the charger in the battery came back on line. Also if he disconnected the the battery then reconnected it would come bake on. His was a Gen 1 battery ECO replaced it with Gen 2 which came with a different BMS, meter and different cable from battery to meter. Still no Bluetooth.
PuttPutt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
RXV w/ no power, unable to move w/ Eco Battery Electric EZGO
Unable to find charger?? Help? Lithium EZGO
93 Club Car unable to stay at any speed without drop in power Gas Club Car
unable to view Test Post


All times are GMT -5. The time now is 08:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.