lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-01-2016, 05:00 PM   #1
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Yamaha G1 runs fine in flat ground, not so much on an incline

The compression was a bit low when I tested it, but it pulls hills fine once it's running. It's really sluggish to start. Changed the carb, muffler, air filter, pre mixed my has. Nothing changes it. Is the compression really the culprit or am I missing something before I tear this thing all apart.
elcap is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
IQ car dies while running on flat ground Electric Club Car
2000 club cad DS model Real fast on flat ground but will not climb a hill for nothing Electric Club Car
Works fine off the ground ! Electric EZGO
02 ds IQ 22 mph on flat ground? Electric Club Car
Runs fine but low power! Gas EZGO


All times are GMT -5. The time now is 08:00 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.