lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-13-2022, 04:02 PM   #1
TB72
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2020
Location: Albemarle NC
Posts: 50
Default 2016 txt48 no go!!

Hey guys! Iíve got a txt48 that has issues. Trojan batteries 51volts, reverse alarm works. Most of the time the solenoid doesnít activate, but then there are times it does. Even when it does, cart barley tries to move, then nothing again.
Had my meter checking a few things and noticed there is voltage on the cart frame! Around 4.6 volts when the cart is in tow mode and drops to around 2volts when you flip toggle to run. Any help/ideas greatly appreciated!!
TB72 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-13-2022, 04:55 PM   #2
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 73,397
Default Re: 2016 txt48 no go!!

Most carts show a little frame voltage without any issues.
Check to see if there is 48v measured between the 2 small solenoid posts when you try to go and the solenoid does not click. If yes and not click replace the solenoid.
If no check the pedal box. This cart has a micro switch in the pedal box under the floor.
scottyb is offline   Reply With Quote
Old 08-13-2022, 06:38 PM   #3
TB72
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2020
Location: Albemarle NC
Posts: 50
Default Re: 2016 txt48 no go!!

51 volts on both small solenoid post even when it doesnít click..... so change the solenoid???
TB72 is offline   Reply With Quote
Old 08-13-2022, 08:09 PM   #4
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 13,120
Default Re: 2016 txt48 no go!!

Solenoid will have pack voltage on both small terminals until the controller sends it a ground. 48txt carts have a sonic weld of wires that feed power circuits that is known to fail. It is in the wire loom just in front of the controller. Try moving it around and see if the cart runs. If so you need to pull it apart and reconnect that weld.
kgsc is offline   Reply With Quote
Old 08-13-2022, 10:41 PM   #5
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 73,397
Default Re: 2016 txt48 no go!!

My post read "48v measured between the 2 small solenoid posts" when you try to go. Not measuring from the main (-), but between the posts.
scottyb is offline   Reply With Quote
Old 08-14-2022, 07:01 AM   #6
kah00na
Not Yet Wild
Columbia
 
Join Date: Jul 2022
Location: Kansas
Posts: 16
Default Re: 2016 txt48 no go!!

I have a 36v cart and I was measuring all 36v going through the frame (with the multimeter's positive connected to frame and negative connected to the last battery's negative post). One of the older wires connecting to the solenoid had some of the rubber coating gone and it was touching the frame. I replaced that wire with a new one and the frame voltage is gone now.
kah00na is offline   Reply With Quote
Old 08-14-2022, 09:52 AM   #7
TB72
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2020
Location: Albemarle NC
Posts: 50
Default Re: 2016 txt48 no go!!

Ok. Thanks. I misunderstood. No voltage between the two small post when it doesnít click. I will check pedal box and report back.
TB72 is offline   Reply With Quote
Old 08-14-2022, 10:51 AM   #8
TB72
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2020
Location: Albemarle NC
Posts: 50
Default Re: 2016 txt48 no go!!

Micro switch in pedal box test good. Voltage at black/white wire at ITS is 15v with the two wires unplugged from ITS but when you plug them back in voltage is around 3.2v and doesnít change no matter the throttle position.
TB72 is offline   Reply With Quote
Old 08-14-2022, 11:20 AM   #9
TB72
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2020
Location: Albemarle NC
Posts: 50
Default Re: 2016 txt48 no go!!

After checking micro switch again, it test good when the red and green wires are unplugged, but after the wires are connected, the switch does NOT break continuity.
TB72 is offline   Reply With Quote
Old 08-14-2022, 11:27 AM   #10
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 13,120
Default Re: 2016 txt48 no go!!

Here is the diagram for that cart. Red wire should have pack positive voltage..
Attached Images
File Type: jpeg 4F95E4DC-07C0-4C0B-B021-BDC7AFDCFE22.jpeg (54.3 KB, 0 views)
kgsc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2016 TXT48 dead Electric EZGO
2016 TXT48 Run/Tow switch wiring Electric EZGO
2016 TXT48 Speed increase? Electric EZGO
2016 TXT48 Diagnostic Mode? Electric EZGO
2016 TXT DCS/PDS/TXT48 Identification Electric EZGO


All times are GMT -5. The time now is 08:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.