lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car
Gas Club Car Gas DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-18-2011, 08:33 AM   #1
hotrodelrod
Not Yet Wild
 
Join Date: Aug 2010
Posts: 22
Default 02 DS generator issues?

Hey all,

My 02 ds wont start when the voltage drops below 12.5v. Anything above that and it works fine. I can put a fresh charge on the battery, run it for awhile, maybe even a couple of days, but ultimately the voltage drops below 12.5 or so and nada! I replaced the generator a couple of years ago. Is it bad again or is there something else that could be wrong? Thanks in advance,
Rick in VA
hotrodelrod is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 09-18-2011, 08:43 AM   #2
essness
Not your usual outlaw
 
essness's Avatar
Yamaha
 
Join Date: Oct 2008
Location: Near Lake Geneva, WI
Posts: 20,054
Default Re: 02 DS generator issues?

Quote:
Originally Posted by hotrodelrod View Post
Hey all,

My 02 ds wont start when the voltage drops below 12.5v. Anything above that and it works fine. I can put a fresh charge on the battery, run it for awhile, maybe even a couple of days, but ultimately the voltage drops below 12.5 or so and nada! I replaced the generator a couple of years ago. Is it bad again or is there something else that could be wrong? Thanks in advance,
Rick in VA
Rick, how old is your battery? Yoy may want to replace it. You can load test it and I would bet your dropping way down when the starter kicks in.
essness is offline   Reply With Quote
Old 09-18-2011, 08:55 AM   #3
hotrodelrod
Not Yet Wild
 
Join Date: Aug 2010
Posts: 22
Default Re: 02 DS generator issues?

Scot, the battery is only a year or two old but I will test it. Thanks for your help!
hotrodelrod is offline   Reply With Quote
Old 09-18-2011, 09:03 AM   #4
essness
Not your usual outlaw
 
essness's Avatar
Yamaha
 
Join Date: Oct 2008
Location: Near Lake Geneva, WI
Posts: 20,054
Default Re: 02 DS generator issues?

Quote:
Originally Posted by hotrodelrod View Post
Scot, the battery is only a year or two old but I will test it. Thanks for your help!
I replace mine every 2 years. It seems with the limited use, (I use mine year round) they just dont make it much beyond that.
essness is offline   Reply With Quote
Old 09-18-2011, 10:26 AM   #5
hotrodelrod
Not Yet Wild
 
Join Date: Aug 2010
Posts: 22
Default Re: 02 DS generator issues?

OK, battery was suspect but Still something wrong. I put the cart on stands and ran it. I am getting 15+ volts out of the generator top post and then to the solnoid post opposite of battery connection but no voltage is being sent back to battery. It hovers around 11.9-12v while running. What sends the voltage from the solnoid to the battery? Thanks, Rick
hotrodelrod is offline   Reply With Quote
Old 09-18-2011, 11:05 AM   #6
invalidsession
Gone Wild
E-Z-GO
 
Join Date: Aug 2009
Location: Eldon Missouri
Posts: 977
Default Re: 02 DS generator issues?

Voltage regulator.

Chris.
invalidsession is offline   Reply With Quote
Old 09-18-2011, 11:12 AM   #7
shadowman
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 02 DS generator issues?

Quote:
Originally Posted by invalidsession View Post
Voltage regulator.

Chris.


i agree the voltage regulator................................
shadowman is offline   Reply With Quote
Old 09-18-2011, 08:16 PM   #8
Jimmie
Gone Wild
Club Car
 
Join Date: Oct 2009
Location: Lee County, Georgia
Posts: 521
Default Re: 02 DS generator issues?

Quote:
Originally Posted by hotrodelrod View Post
OK, battery was suspect but Still something wrong. I put the cart on stands and ran it. I am getting 15+ volts out of the generator top post and then to the solnoid post opposite of battery connection but no voltage is being sent back to battery. It hovers around 11.9-12v while running. What sends the voltage from the solnoid to the battery? Thanks, Rick
Sounds like your solenoid is not staying picked up or bad internal contact.
Jimmie is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Generator 101 Gas Club Car
powerdrive 2 issues and speed issues. Electric Club Car
Want to convert 48 volt battery club car to generator powered ( Honda 2000i generator Electric Club Car
Generator Gas Club Car
Generator Gas EZGO


All times are GMT -5. The time now is 08:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.