lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-18-2011, 12:16 AM   #1
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default EZ-GO Marathon not cranking

Hi again guys, hope you can help me again.I searched for this problem in the forums but I cannot find it.

I have a 1988 Marathon with the Robin engine and external Hitachi generator/starter.

My cart will not crank, the reverse warning buzzer is constantly going off, key on or off, any position of the FNR switch.

I've taken the FNR switch apart and cleaned the big copper contacts with fine sandpaper.No luck there.Before, I was able to hold the pedal down and tap the solenoid and get the engine to jump a little bit but it would not crank.Now it won't even click and the solenoid tapping does nothing.

Today I put in a Ford solenoid, just to help diagnose it, but it did pretty much the exact same thing.I jumped the two posts on the solenoid and it will crank over.I know the Ford solenoid isn't good to use, I just wanted to see if it would work.

Not sure where to go from here...
Heliarc is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-18-2011, 01:33 AM   #2
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: EZ-GO Marathon not cranking

Sounds like either the accelerator mirco switch or F/R mirco switch. Check for a broken wire on the accelerator switch the one at the bottom or switch maybe bad.One of the wires goes to the F/R switch the other goes to the soleinoid small terminal closest to the drivers side.You can check to see if you have power at this terminal with the peddle depressed if not the solenoid won't close.
racin161 is offline   Reply With Quote
Old 10-18-2011, 01:35 AM   #3
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: EZ-GO Marathon not cranking

Oh and dump the ford solenoid I understand its just for a test but it won't last.See the other post about them. GOOD LUCK keep us posted.
racin161 is offline   Reply With Quote
Old 10-18-2011, 12:23 PM   #4
ScooterMcTavish
Gone Wild
 
ScooterMcTavish's Avatar
E-Z-GO
 
Join Date: Oct 2009
Location: Manitoba, Canada
Posts: 363
Default Re: EZ-GO Marathon not cranking

Also, get hands on with all of the connectors - with these old carts it is so easy for a wire to corrode underneath it's insulation, or within it's spade connector.
ScooterMcTavish is offline   Reply With Quote
Old 10-18-2011, 12:40 PM   #5
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: EZ-GO Marathon not cranking

Yea, don't worry, the Ford solenoid isn't staying there.That sucker cost $18 and I don't want to burn it up.

One thing I should mention, the reverse alarm does change pitch when I hit the pedal so I think at least the wiring is good to and from it.Going to have a look at it anyhow though.Looking underneath, there's a good deal of mud underneath so maybe that switch just isn't making connection anymore.I imagine I could test that by jumpering across the switch right?Then if it cranks, I got my problem.
Heliarc is offline   Reply With Quote
Old 10-18-2011, 02:52 PM   #6
racin161
Gone Wild
 
Join Date: Feb 2011
Posts: 1,515
Default Re: EZ-GO Marathon not cranking

YEP
racin161 is offline   Reply With Quote
Old 10-18-2011, 06:32 PM   #7
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: EZ-GO Marathon not cranking

Thanks kindly.Hopefully I can get on it tomorrow if the rain holds off, if not we'll know soon enough.
Heliarc is offline   Reply With Quote
Old 04-16-2012, 08:09 PM   #8
Heliarc
Warthog cart
 
Heliarc's Avatar
E-Z-GO
 
Join Date: Aug 2011
Posts: 502
Default Re: EZ-GO Marathon not cranking*Cranking, sparking and Almost running*

Guys, I am so excited.A few months ago when I put in the automotive solenoid I messed up the wiring and I got disheartened.Well my wifes birthday is coming up and she is in love with that golf cart.We got to borrow it for awhile a few years back.Since I don't have much money I thought this should be a good way to show my appreciation.It's totally not for me to buzz around on the mountain on in any way.

I made up my mind that I WOULD get the **** thing going one way or another.I even though about swapping in a briggs ten horse but that wasn't quite feasible.

So I got my hands on a wiring schematic from here.Within ten minutes I had it cranking AND sparking right off the pedal, then my accel switch crapped out...So I bypassed it.Then I removed the carb and fuel pump and went at them with cleaner and an air compressor.Carefully with the pump of course.

Next, I put in a gallon of 100:1 premix, cranked it over and it nearly wanted to keep running.I got some farts, bangs and a few seconds of it actually running.Only thing I forgot was to empty the tank of the stale gas, water, and Mississippi mud out of the tank.Tomorrow I'll have it.I know it.

My one real issue though is a major short when I try and crank it in reverse.I put the switch in reverse, bypass the accel switch to crank it, and I can literally watch the main ground cable jump from the juice that this short is pulling.I've already had the switch apart, cleaned those big copper lugs, and it went back together nicely so I don't think I've botched anything there.Also I didn't have to disconnect any of the wires to get it apart enough to clean it.Is my starter fried just in reverse somehow?

One more question.I have tons of toggle switches around.Would there be problem with replacing the accel switch with a toggle?I would like to try and clean the accel switch properly, or get a new one if I have to, but for awhile I don't see the difference where the switch is.

Thanks guys, you've helped me out of a rough spot.
Heliarc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
cranking problem Gas EZGO
cranking noises at startup and slow down Gas EZGO
Weird cranking noises on gear shift Electric EZGO
88 CC gasser no spark while cranking Gas Club Car


All times are GMT -5. The time now is 08:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.