lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-09-2010, 12:07 PM   #1
RedNeck Rhino
Getting Wild
 
RedNeck Rhino's Avatar
 
Join Date: Apr 2008
Location: New Albany, MS
Posts: 110
Default G1's got spark but no start!

I'll try to make this as detailed as possible.
I recently replaced my carb with an oem replacement, and replaced my air filter with a K&N. I couldn't mount the filter directly to the carb cuz it would hit the throttle spring assembly so I used the stock hose that went to the airbox and clamped the filter to the airbox end. Probably doesn't matter but like I said "detailed". The old carb didn't have an extra hose, the new one does. I'm assuming this is the oil hose and I should probably plug it cuz I premix my fuel. After the replacements I noticed that it took a little longer to start than before, but it did start and ran well so i figured the carb just needed to be adjusted. Now it won't start at all. It will hit a lick every now and then, but seems to just flood out. I pulled the plug and it was wet but sparks like a champ. So now here come the questions.
Is it the oil hose left open?
Does the carb just need to be adjusted?
Is it the K&N filter?
Do I need to jet my carb because of the K&N filter?
If I jet my carb do I need a better muffler?
How many licks does it take to get to the center of a tootsie pop?

thanks, Ben
RedNeck Rhino is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-09-2010, 06:07 PM   #2
TheNewGuy
Admin/Moderator
 
TheNewGuy's Avatar
Yamaha
 
Join Date: Dec 2006
Location: Ohio
Posts: 17,249
Default Re: G1's got spark but no start!

Quote:
Originally Posted by RedNeck Rhino View Post
I'll try to make this as detailed as possible.
I recently replaced my carb with an oem replacement, and replaced my air filter with a K&N. I couldn't mount the filter directly to the carb cuz it would hit the throttle spring assembly so I used the stock hose that went to the airbox and clamped the filter to the airbox end. Probably doesn't matter but like I said "detailed". The old carb didn't have an extra hose, the new one does. I'm assuming this is the oil hose and I should probably plug it cuz I premix my fuel. After the replacements I noticed that it took a little longer to start than before, but it did start and ran well so i figured the carb just needed to be adjusted. Now it won't start at all. It will hit a lick every now and then, but seems to just flood out. I pulled the plug and it was wet but sparks like a champ. So now here come the questions.
Is it the oil hose left open? Should be capped off.
Does the carb just need to be adjusted?Yes
Is it the K&N filter?See below.
Do I need to jet my carb because of the K&N filter?Yes, you are giving it more air, should give more fuel.
If I jet my carb do I need a better muffler?It may need more flow.
How many licks does it take to get to the center of a tootsie pop?4,629


thanks, Ben

TheNewGuy is offline   Reply With Quote
Old 06-09-2010, 08:26 PM   #3
RedNeck Rhino
Getting Wild
 
RedNeck Rhino's Avatar
 
Join Date: Apr 2008
Location: New Albany, MS
Posts: 110
Default Re: G1's got spark but no start!

Thanks Ron.
I came home from work and capped the oil hose. I finally got the thing to start up, but it's still not right. Seems to surge and then bog over and over then run good then bog, you get the picture. I'm gonna try to get it up on some jack stands this weekend and yank that black and white wire loose that makes it keep running so maybe I can tune it a little better. I was planning on cooking the muffler this weekend anyway.
I know I'm not gonna find a jet kit for this carb so how big do I need to drill it out?
I didn't really want to swap mufflers, but if I have to I think I know where a blaster pipe is that I can probably get cheap, if not free. I just didn't want to have the extra noise.

thanks again, Ben
RedNeck Rhino is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
newbie question on the g1's Gas Yamaha
1980 ezgo gas SPARK/NO SPARK Gas EZGO
91 Marathon I have gas I have spark won't start Gas EZGO
83 Robin EZGO has spark no start Gas EZGO
Big block G1's Big Block Talk!


All times are GMT -5. The time now is 08:25 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.