lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-11-2011, 10:41 AM   #1
CEBERS
Not Yet Wild
 
Join Date: Feb 2011
Posts: 1
Default 94 gas ezgo

i have a 94 ezgo, died in flight, no response from pedal, no crank, nada. engine will turn but will not fire when starter solonoid is jumped. have relaced solonoid, ignitor, and fuse before solonoid. still nothing. am i missing something? is there a fuse or relay somewhere else? thanks for any help.
CEBERS is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-11-2011, 11:37 AM   #2
BrewCityMusic
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: 94 gas ezgo

Try checking the microswitch under the gas pedal, also the keyswitch - those both need to work to trigger your solenoid, and if either one is bad, even if you jump the solenoid you won't get spark (trust me, I chased those around myself awhile back)
BrewCityMusic is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 01:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.