lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-23-2012, 01:59 PM   #1
fritster
Gone Wild
 
fritster's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: God's country.. Luziana
Posts: 274
Default transaxle slipping help

I put my OEM transaxle gears back in today. Put the rear end back together and the **** thing is slipping and will not hardly take off. I used 30 sae engine oil (same as before) and cannot figure out why its slipping

I can hear a screeching noise like springs or metal rubbing. I found shavings in the oil. The transmission works, it goes in forward and reverse.

IS IT MY DIFFERENTIAL CLUTCH? I just cant see how it can be the gear thing, everything works as far as it going in forward/reverse and neutral.

Please anyone that can help?
fritster is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-23-2012, 02:38 PM   #2
fritster
Gone Wild
 
fritster's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: God's country.. Luziana
Posts: 274
Default Re: transaxle slipping help

Am I missing a keyway somewhere, I never saw one, but I think I hurried to much?
fritster is offline   Reply With Quote
Old 03-23-2012, 08:33 PM   #3
fritster
Gone Wild
 
fritster's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: God's country.. Luziana
Posts: 274
Default Re: transaxle slipping help

tearing back down tomorrow :( I think that the splines stripped on the axle or in the diff because there si NO key way in my axle, the ring gear bolts to the diff and the small gear is splined.
fritster is offline   Reply With Quote
Old 03-24-2012, 06:11 PM   #4
fritster
Gone Wild
 
fritster's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: God's country.. Luziana
Posts: 274
Default Re: transaxle slipping help

Problem solved. The dummy at the mechanic shop that pressed off my bearing and changed the ring gear for me, dropped the spider gear that goes in the diff, under the ring gear and never even noticed. I went back to the mechanic shop and sure enuff, there it was next to the press on the cement. WTF? DO IT URSELF or u get screwed?

Anyone have an old 4 cycle ezgo transaxle for parts? I need the 3 spacers that go on the shaft of one of the gears. For some reason, mine are missing and I doubt I can get those form EZGO?
fritster is offline   Reply With Quote
Old 03-24-2012, 08:47 PM   #5
rib33024
......................
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 16,264
Default Re: transaxle slipping help

That sucks when you take some thing to the shop and they do some thing stupid like that, glad you found out what it was
rib33024 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Transaxle Swap/Yamaha Transaxle, Good Deal? Lifted Golf Carts
Clutch slipping? G9 Gas Yamaha
G2 slipping Gas Yamaha
belt slipping Gas Yamaha
03 slipping problem Gas EZGO


All times are GMT -5. The time now is 01:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.