lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-03-2021, 11:14 PM   #21
Mooncarter
Gone Insane
 
Mooncarter's Avatar
Club Car
 
Join Date: Oct 2016
Location: Richmond, VA
Posts: 13,152
Default Re: 2003 DS IQ restoration

Wow this thread has gone all over the map!
Mooncarter is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-04-2021, 12:24 AM   #22
simicrintz
Gone Wild
 
simicrintz's Avatar
Club Car
 
Join Date: Apr 2020
Location: San Diego
Posts: 654
Default Re: 2003 DS IQ restoration

I'll admit to forgetting what it initially was about!
simicrintz is offline   Reply With Quote
Old 01-04-2021, 08:49 AM   #23
sefrlw
Not Yet Wild
Club Car
 
Join Date: Dec 2020
Location: NC
Posts: 14
Default Re: 2003 DS IQ restoration

Quote:
Originally Posted by simicrintz View Post
WHAT??!! I demand a ruling-those letters don't add up with those words!!!
U is you so close enough.

Blank Off Cause U Stupid.... not you of course!
sefrlw is offline   Reply With Quote
Old 01-04-2021, 08:50 AM   #24
sefrlw
Not Yet Wild
Club Car
 
Join Date: Dec 2020
Location: NC
Posts: 14
Default Re: 2003 DS IQ restoration

Quote:
Originally Posted by simicrintz View Post
I'll admit to forgetting what it initially was about!
It all started due to me being stupid. Just not revealing how...
sefrlw is offline   Reply With Quote
Old 01-04-2021, 10:37 AM   #25
simicrintz
Gone Wild
 
simicrintz's Avatar
Club Car
 
Join Date: Apr 2020
Location: San Diego
Posts: 654
Default Re: 2003 DS IQ restoration

I am on quite a few different forums (and moderate one of them); so cool when I see folks that have a good sense of humor! You are gonna fit in well here!!
simicrintz is offline   Reply With Quote
Old 01-04-2021, 11:49 AM   #26
Wakko47
Gone Loco
 
Wakko47's Avatar
Club Car
 
Join Date: Jul 2020
Location: South Florida
Posts: 1,042
Default Re: 2003 DS IQ restoration

Quote:
Originally Posted by simicrintz View Post
I am on quite a few different forums (and moderate one of them);
I thought I'd seen your name on the Furry Forum!
Wakko47 is online now   Reply With Quote
Old 01-04-2021, 06:50 PM   #27
simicrintz
Gone Wild
 
simicrintz's Avatar
Club Car
 
Join Date: Apr 2020
Location: San Diego
Posts: 654
Default Re: 2003 DS IQ restoration

Quote:
Originally Posted by Wakko47 View Post
I thought I'd seen your name on the Furry Forum!
I am really afraid to go look that up!!
simicrintz is offline   Reply With Quote
Old 01-05-2021, 05:46 PM   #28
sefrlw
Not Yet Wild
Club Car
 
Join Date: Dec 2020
Location: NC
Posts: 14
Default Re: 2003 DS IQ restoration

Well cart peeps. After waiting on parts the cart is fixed as is the charger. It is charging away as I type. Thank you for making me read the troubleshooting a umpteenth time. The key was the clicking of the relay not happening and I simply failed to register that statement along with another mistake. Relay showed up today and has been replaced. You guys rock
sefrlw is offline   Reply With Quote
Old 01-10-2021, 05:33 PM   #29
sefrlw
Not Yet Wild
Club Car
 
Join Date: Dec 2020
Location: NC
Posts: 14
Default Re: 2003 DS IQ restoration

On to my next issue. I think my speed sensor is not working.. I am stuck at 8 mph. I did the sensor testing. I stop on a slight incline in my driveway and it just keeps rolling when let off the brake. It does beep and I can push it but it never brakes to keep me from pushing it. So is that the speed sensor or maybe the FET? Going downhill it will run 12-15 and brake somewhere around 15.
sefrlw is offline   Reply With Quote
Old 01-17-2021, 01:09 PM   #30
sefrlw
Not Yet Wild
Club Car
 
Join Date: Dec 2020
Location: NC
Posts: 14
Default Re: 2003 DS IQ restoration

So I am in the process of doing the speed sensor test. I get voltage fluctuation 0ish to 5.02 ish on pack - to green wire in RUN and Cart key off. On to the next test. Is MPP post the main positive on the battery pack? If so I get 0 on the black and white wire and if MPN is negative on the battery pack I get 15.31/2 so I am thinking the speed sensor is not getting power from the controller? Is there a fuse I canít see? If not I am thinking I need a controller 😔
sefrlw is offline   Reply With Quote
Reply

Tags
charging issues
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Restoration '86 Electric EZGO
almost done with the restoration Gas EZGO
g2 restoration Gas Yamaha
my restoration Gas Club Car
e-z-go restoration Electric EZGO


All times are GMT -5. The time now is 07:41 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.