lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-13-2021, 08:43 PM   #1
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Question 2014 RXV Fails

Good Evening,

I have a 2014 RXV that has been great for the first year of ownership. This year, its been nothing but trouble. The dealership place near me wants 800$ to pickup, troubleshoot and whatever is wrong with it so I have been trying to read the posts and figure it out.

Here is what happened. I parked it for the night and when I tried to use the next day, it would double click like normal but no click when you press the throttle. I reversed the 1/2/3/4 connectors to free the brake and move it out of the way.

I replaced the solenoid and the 7.5amp fuse that I found blown and its still not moving.

The tow switch does nothing when selected. The cart when in the run position does click 2 times from the solenoid when I move the key from off to Forward or Backwards but that's it.

Pack voltage is 49.3-50.4 tested with multimeter. (depends on charge level when tested)

I seems difficult to troubleshoot without a reader. Maybe that's what I need to do to figure this out once and for all.

I appreciate the assistance. I wish I had a trailer and a vehicle to tow it to the dealership but 800$ seems crazy just to see what's wrong with it.
upnorthguy is offline   Reply With Quote
Old 09-13-2021, 09:22 PM   #2
bbbdale
Gone Wild
 
bbbdale's Avatar
 
Join Date: Mar 2016
Posts: 228
Default Re: 2014 RXV Fails

Good luck. usgicollector will be along shortly to give you some advice.

I bought my non-running Ď13 RXV in May and Iím still trying to clean up the cobwebs

New batteries fixed my 1st issue. New input shaft fixed my 2nd issue. Now maybe a new reverse buzzer will fix my 3rd issue.

Here I thought I had gotten a deal at $2000.



Sent from my iPhone using Tapatalk
bbbdale is offline   Reply With Quote
Old 09-13-2021, 09:29 PM   #3
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

Gosh, I got mine for 2k as well. worked great for a year then this year its been a nightmare.
upnorthguy is offline   Reply With Quote
Old 09-14-2021, 05:19 AM   #4
usgicollector
Gone Wild
E-Z-GO
 
Join Date: Mar 2014
Location: NE Indiana & SW Florida
Posts: 2,528
Default Re: 2014 RXV Fails

Sounds like your not passing the startup test. Get the Curtis troubleshooting guide and do some checking. This could be just a bad switch you need to check a few things.
usgicollector is offline   Reply With Quote
Old 09-14-2021, 03:07 PM   #5
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

With the startup guide can you do some of the tests without the controller programmer?
upnorthguy is offline   Reply With Quote
Old 09-14-2021, 03:17 PM   #6
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

Iím trying to find the startup guide now. So far I keep finding a coffee pot model haha.
upnorthguy is offline   Reply With Quote
Old 09-14-2021, 05:02 PM   #7
usgicollector
Gone Wild
E-Z-GO
 
Join Date: Mar 2014
Location: NE Indiana & SW Florida
Posts: 2,528
Default Re: 2014 RXV Fails

Here you go.
Attached Files
File Type: pdf RXV 48V AC Curtis Advanced Trouble-Shooting Guide.pdf (3.16 MB, 0 views)
usgicollector is offline   Reply With Quote
Old 09-15-2021, 05:10 PM   #8
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

Thanks for the info. I went out and bought a brand new multimeter because I was testing the throttle switches and I get NOTHING. Same with the new Multimeter. 0 volts detected. I followed the guide and put the key to the forward position and I hear the clunk and two clicks then I test.

So I should start with that maybe?
upnorthguy is offline   Reply With Quote
Old 09-19-2021, 12:41 PM   #9
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

Got to testing today with an actual car mechanic. We found the electronic brake to be failed. Itís testing 3.4 and blowing the fuse.
upnorthguy is offline   Reply With Quote
Old 09-20-2021, 08:18 PM   #10
upnorthguy
Not Yet Wild
 
Join Date: Sep 2021
Posts: 7
Default Re: 2014 RXV Fails

Bought a oem replacement brake. Itís different than mine. Nothing lined up. Canít get the screws to thread in whatsoever. Horrible design. Iím ready to junk it and get a club car has that someone nearby is selling.
upnorthguy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G9 - Spark fails after 1-20 seconds Gas Yamaha
2009 ITS constantly fails Electric EZGO
If all else FAILS use a V-Glide..!!! Electric golf carts
Yamaha g22 fails to go Gas Yamaha
New winch fails on big hill!!! wth would you do? Lifted Golf Carts


All times are GMT -5. The time now is 06:00 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.