lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-16-2016, 12:24 PM   #1
thecrustychicken@gmail.co
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2016
Location: Stephenville, TX
Posts: 1
Unhappy 2013 Badboy Ambush Not Running

Greetings everyone,

First off, glad to find your site! It's great there are so many trying to help each other.

I have a 2013 model Badboy Ambush. (I know, I know) after reading all the problems with them.

I was driving mine for the past few days. I've noticed while driving it, that it would slow down at random times. I could let out on the throttle peddle, press it again and it would seem to speed up again. Well yesterday after going on a ride, In Gas Mode, it just died all of a sudden. I can depress the throttle peddle and the starter/generator turns the engine, but it will not start. Another thing, when I put it in electric mode, and just press on the peddle just a little bit, it will start rolling really slow. If I depress the peddle further to speed up the cart will make a high pitch whine and stop again. Got it home finally on battery power just depressing the peddle every so slightly and going about 1 or 2 mph. LOL Took almost an hour.

So the question is, I think maybe my throttle position sensor might be bad per the slowing down and speeding up symptoms from days past. Going to check all connections for tightness today and see if I can find any problems. I know these buggies have problems with the actuators which I know that my transmission is switching properly.

Does anyone know if there is a physical cable between the pedal and the carb on the motor? If the carb on the gas side is also a "fly by wire" connection then that might explain why the motor wouldn't run because it doesn't know the proper position of the peddle.

I did score a wiring diagram for the electric and gas circuits from Textron this morning, so I'm going to start going through the electrical system and see if I can figure it out.

Any suggestions of what to check would be greatly appreciated!

While my fiance was walking beside the cart as I was going 1 mph back to the house because it wouldn't pull us both up the hill, I was singing the theme song to COPS out loud!!! LOL If I came for you on this thing, you could get away by just walking!!!

Once again,

Thanks for your help!!

Justin McClure
Stephenville, TX
thecrustychicken@gmail.co is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-24-2017, 07:53 AM   #2
Nickp76
Not Yet Wild
 
Join Date: Jun 2017
Posts: 3
Default Re: 2013 Badboy Ambush Not Running

Hello Justin...Im the "proud" owner of a used 2013 ambush as well.... NOT running of course. Any luck you still have the wiring diagram I could bum off of you. Thanks NIck
Nickp76 is offline   Reply With Quote
Old 10-11-2017, 08:01 AM   #3
eightfoot8
Not Yet Wild
 
Join Date: Oct 2017
Posts: 5
Default Re: 2013 Badboy Ambush Not Running

I have the 150 page service training manual in mailable form if you would like, I've just bought a 2014 ambush is and am having several problems as well
eightfoot8 is offline   Reply With Quote
Old 11-30-2018, 08:10 AM   #4
wa5eml
Not Yet Wild
 
Join Date: Nov 2018
Posts: 8
Default Re: 2013 Badboy Ambush Not Running

Where did you get the Service manual? The local distributor says they don't have one. I would love to get a copy of one. I have the mechanical and electrical ability to trouble shoot the thing only if I had a wiring diagram and flow charts.
wa5eml is offline   Reply With Quote
Old 12-04-2018, 02:35 PM   #5
Erle
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2016
Location: Mendenhall, Mississippi
Posts: 29
Default Re: 2013 Badboy Ambush Not Running

Give me a way to contact you. I can email you a copy of the service manual. Who knows--since I own one of the lemons myself, I might need your suggestions in the future.

ALSO--is the WA5EMI a Ham Radio Call? I'm a Ham myself.

Erle
Erle is offline   Reply With Quote
Old 12-08-2018, 09:37 AM   #6
wa5eml
Not Yet Wild
 
Join Date: Nov 2018
Posts: 8
Default Re: 2013 Badboy Ambush Not Running

Quote:
Originally Posted by Erle View Post
Give me a way to contact you. I can email you a copy of the service manual. Who knows--since I own one of the lemons myself, I might need your suggestions in the future.

ALSO--is the WA5EMI a Ham Radio Call? I'm a Ham myself.

Erle
Erle,
Wa5EML is a ham call. I am good on QRZ for contact info.
I have a 2014 Bad Boy Ambush iS that the gas side does not crank and or run. The Electric motor will run only in certain circumstances. With the rocker switch on the dash board in electric if the key is turned to either R or F and the controller initializes to that position it will work perfectly in those two positions. If I switch the key from off to N and the controller initializes in that position, moving the key to R or F does nothing - no LED indicator changes, anything. To re initialize the key must be turned off then quickly turned to either the R or F position. If the key is in R and the buggy has initialized in that position it will run in reverse. If the key is moved to any other position there is no LED indicator change. Therefore if the key is moved from the working R position to the F, nothing happens to indicators or cart function.
I am looking for a service manual to track wires and connections between the controller (which was just dealer replaced in April).
How can I get a copy? The dealer has been no help and ignoring any effort to communicate. I know they only sold 4 of these locally. I know one of the others was sold to a high profile business man and he has had problems as well.
wa5eml is offline   Reply With Quote
Old 12-08-2018, 12:26 PM   #7
Erle
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2016
Location: Mendenhall, Mississippi
Posts: 29
Default Re: 2013 Badboy Ambush Not Running

I'm not a subscriber to QRZ. I'm WA5UDQ in Mississippi. Been a Ham or 63yrs.

Give me an email address & I'll attach the service manual to you.

Erle
Erle is offline   Reply With Quote
Old 12-08-2018, 10:49 PM   #8
wa5eml
Not Yet Wild
 
Join Date: Nov 2018
Posts: 8
Default Re: 2013 Badboy Ambush Not Running

wa5eml@yahoo.com
wa5eml is offline   Reply With Quote
Old 03-05-2019, 07:59 PM   #9
sadewill64@msn.com
Not Yet Wild
 
Join Date: Mar 2019
Posts: 1
Default Re: 2013 Badboy Ambush Not Running

Do you have an electrical diagram I could get from you for 2013 bad boy ambush
sadewill64@msn.com is offline   Reply With Quote
Old 03-09-2019, 04:10 PM   #10
Erle
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2016
Location: Mendenhall, Mississippi
Posts: 29
Default Re: 2013 Badboy Ambush Not Running

Check your email.
Erle is offline   Reply With Quote
Reply

Tags
2013, ambush, badboy
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Anyone have any feedback about the Bad Boy Buggie Ambush? Hunting and Fishing
2013 Bad Boy Ambush Actuator Problems Electric EZGO
bad boy ambush shifting actuator Gas EZGO
2013 Bad Boy Ambush Actuator Problem Electric Club Car
BadBoy Ambush IS state of charge meter proble Electric EZGO


All times are GMT -5. The time now is 04:21 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.