lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-10-2012, 11:42 AM   #11
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 18,811
Default Re: PDS Sudden/ total power loss??

Here's a chart showing where to attach DVM negative test lead.

The voltages at both 4 & 5 originate at the battery, so it doesn't matter what positions, Run/Tow, F/R or Key switches are in.
JohnnieB is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-13-2012, 08:47 AM   #12
Paxdad
Gone Wild
 
Paxdad's Avatar
E-Z-GO
 
Join Date: Aug 2008
Location: Cumming, GA
Posts: 313
Default Re: PDS Sudden/ total power loss??

JohnnieB,
Thanks for getting me going in the right direction. I believe that the cause stemmed from the SOG. Apparently the + spade on the 1 position of the gauge fell off and struck the
(-) #2 post/ spade on the gauge. Whoever put the gauge and wiring in used the spade connectors that are unisulated. The postive of the gauge was hooked to the charger 60 amp fuse which as you can imagine took out the fuse and subsequently the B+ to the number 4 pin connector on J1 via the reed switch. I replaced the fuse rewired the SOG and all is good now. Hopefully this makes sense. Again this was all prompted by a lightning strike at the owners house when they left the cart on charge even though the charger had shut off.
Paxdad is offline   Reply With Quote
Old 08-13-2012, 09:17 AM   #13
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 18,811
Default Re: PDS Sudden/ total power loss??

Glad you got it going again.

Also sounds like you figured out what happened.

FWIW: I leave my cart on float charge, but I run my charger through a surge protector.
JohnnieB is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Total loss of power during operation Electric EZGO
98 G-16 sudden loss of torque Gas Yamaha
Loss of power Electric Club Car
g9 loss of power Gas Yamaha
Loss of Power Electric EZGO


All times are GMT -5. The time now is 05:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.