lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-01-2016, 05:00 PM   #1
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Yamaha G1 runs fine in flat ground, not so much on an incline

The compression was a bit low when I tested it, but it pulls hills fine once it's running. It's really sluggish to start. Changed the carb, muffler, air filter, pre mixed my has. Nothing changes it. Is the compression really the culprit or am I missing something before I tear this thing all apart.
elcap is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-01-2016, 05:03 PM   #2
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

Could the starter generator belt be the issue? It's seen better days.
elcap is offline   Reply With Quote
Old 06-01-2016, 11:19 PM   #3
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

What did compression read? Are clutches functioning correctly try taking then apartment checking for broken parts and clean and lube with a dry lithium grease
Spicyunicorn is offline   Reply With Quote
Old 06-02-2016, 06:22 AM   #4
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

75-80psi.
elcap is offline   Reply With Quote
Old 06-02-2016, 07:44 AM   #5
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

75 seems really 100 is about the minimum but that being said I'd still try cleaning and lubing the clutchea if that doesn't work you're probably looking at a rebuild
Spicyunicorn is offline   Reply With Quote
Old 06-02-2016, 09:24 AM   #6
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

Yeah, that's what I thought, I'll probably just go the predator route. I know I'll lose reverse, but as it is now I don't have it anyways, the motor can't get the cart going.
elcap is offline   Reply With Quote
Old 06-02-2016, 09:31 AM   #7
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

I don't doubt what you're saying, but would it still run fine once it was running if the rings were bad? It flies once it starts. I just took it out and ran it and the **** thing went 20mph!
elcap is offline   Reply With Quote
Old 06-02-2016, 10:18 AM   #8
Spicyunicorn
Gone Wild
Yamaha
 
Join Date: Jun 2015
Location: NW Iowa
Posts: 1,669
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

It could be a faulty gauge too do you have another one to compare it to? If that's the case it sounds like a clutch issue
Spicyunicorn is offline   Reply With Quote
Old 06-02-2016, 10:56 AM   #9
elcap
Not Yet Wild
 
Join Date: Apr 2014
Posts: 22
Default Re: Yamaha G1 runs fine in flat ground, not so much on an incline

Just thinking it loud here, it sounds like the motor can't free wheel to start. Like it's not turning over fast enough due to drag
elcap is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
IQ car dies while running on flat ground Electric Club Car
2000 club cad DS model Real fast on flat ground but will not climb a hill for nothing Electric Club Car
Works fine off the ground ! Electric EZGO
02 ds IQ 22 mph on flat ground? Electric Club Car
Runs fine but low power! Gas EZGO


All times are GMT -5. The time now is 08:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.