lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-12-2008, 05:16 PM   #1
scott32
Not Yet Wild
 
Join Date: Oct 2008
Posts: 19
Default 1999 48V clubcar

well after being so slow it finally 2 times today i guess hit high gear sort a speak. it pulled really good. it has plenty jusice and the load test seems good. it has a 300 amp controller and i never saw it over 200 amps today while checking it. it really got about 120 amps and then cut back. when it finally took off i did not have a gauge on it. what do yall think is the problem. the solenoid seems fine and the brushes are clean on the motor. the potentiometer seems good. do you think the controller is bad. the controller has the a2 position on it. it is a 36-48 controller. if you think it is going bad does anyone have a used 1 or just what do i need to do. thanks scott
scott32 is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
clubcar blown up? Gas Club Car
help with the body of a clubcar Body and Paint
1994 clubcar Electric Club Car
clubcar carryall 6 Electric Club Car
02 Clubcar IQ For Sale Golf Carts and Parts


All times are GMT -5. The time now is 10:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.