lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 01-29-2017, 07:55 PM   #1
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default Ez go charging

Have an 07 ez go pds. 36 volt New Crown battiers power wise 2 charger. Model 28115 g09. Will run at 10 amps for about an hour the clicks off. Any suggestions?

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 01-29-2017, 08:02 PM   #2
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default

Reed switch is bypassed

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Old 01-29-2017, 09:56 PM   #3
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,443
Default Re: Ez go charging

What's the voltage at the end of that hour at 10a? While the charger is still running. Reed switch should have nothing to do with this.
cgtech is offline   Reply With Quote
Old 01-29-2017, 10:58 PM   #4
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default

15 min unplugged 37.2. - 1 hour later off charger 36.9. - 3 hours later off charger 36.9. I think the battiers are holding charge.

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Old 01-30-2017, 07:56 AM   #5
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,443
Default Re: Ez go charging

I need numbers while the charger is running, not after...
cgtech is offline   Reply With Quote
Old 01-30-2017, 11:43 AM   #6
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default

43.8

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Old 01-30-2017, 12:39 PM   #7
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 19,654
Default Re: Ez go charging

Quote:
Originally Posted by millersouth View Post
Have an 07 ez go pds. 36 volt New Crown battiers power wise 2 charger. Model 28115 g09. Will run at 10 amps for about an hour the clicks off. Any suggestions?

Sent from my SM-G925T using Tapatalk
A Powerwise model 28115 G09 charger is not the same as a Powerwise-II charger. (See attachments)
However they work the same, just different electronics.

Your new batteries are not being fully charged.
After they have off the charger for 12 hours, they ought to read at least 38.2V and at 3 hours they should be reading higher than that. (Voltage vs SoC chart attached)
Attached Images
File Type: jpg PW charger - Faceplate.JPG (447.2 KB, 0 views)
File Type: jpg PW-II charger.JPG (40.3 KB, 0 views)
File Type: jpg SoC vs Voltage - Trojan Battery.JPG (56.9 KB, 0 views)
JohnnieB is offline   Reply With Quote
Old 01-30-2017, 12:44 PM   #8
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default

They were at 35.9. I charged for an hour till the charger cut out. Those number are with only an hour of charge.

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Old 01-30-2017, 12:49 PM   #9
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 11,023
Default Re: Ez go charging

If you can borrow a charger from someone see if it behaves the same way. I'm thinking the logic board is going bad but another charger would help confirm that.
kgsc is offline   Reply With Quote
Old 01-30-2017, 12:56 PM   #10
millersouth
Gone Wild
 
millersouth's Avatar
E-Z-GO
 
Join Date: Feb 2015
Location: Myrtle Beach S.C
Posts: 150
Default

That's what I'm going to do today.

Sent from my SM-G925T using Tapatalk
millersouth is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Gas EZGO
Charging Electric EZGO
2006 TXT 20+amps but not charging, hot charging cable Electric EZGO
Battery Charging Question (How to keep from over-charging) Electric EZGO
? on charging my TXT Electric EZGO


All times are GMT -5. The time now is 03:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.