lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-20-2017, 09:39 AM   #1
jbuczko
Not Yet Wild
 
Join Date: Feb 2017
Posts: 6
Default 2006 Star Classic 2+2 issues

I just purchased a 2006 Star Golf cart and looking for help. It a 48v and has 6 trojan batteries T-875. I have been charging for the last 12 hours and have a collective voltage across all the batteries of 44.6v. When i started it was 36v. What is the minimum amount of voltage that will make sure this cart works. Im not sure if I have a battery issue or controller issue. I cleaned all the terminals before i started charging and checked all the batteries water level. I had to add some water to a couple of batteries. Im just trying to verify if my issues is batteries or controller. It is a Curtis 1268 and i see the status light was giving me a couple of errors. Last night was 5,3 and this morning I'm am getting a 2,5. any help would be grateful.
jbuczko is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-26-2022, 03:34 AM   #2
hardhouseinc
Getting Wild
 
Join Date: May 2022
Posts: 78
Default Re: 2006 Star Classic 2+2 issues

sounds like you have some bad cells and bad batteries

If they are old or sat for long probably no good
hardhouseinc is offline   Reply With Quote
Old 07-26-2022, 04:15 AM   #3
Cartmaster
British born Nincompoop
 
Cartmaster's Avatar
E-Z-GO
 
Join Date: Feb 2007
Location: United Kingdom
Posts: 2,160
Default Re: 2006 Star Classic 2+2 issues

check the voltage of each individual battery and post your results. no need to disconnect them, just put your meter across each battery. You might only have one or two bad ones, and if so source used good ones for testing. Once you know the cart works, then you can invest in a new set.
Cartmaster is online now   Reply With Quote
Old 07-26-2022, 05:53 AM   #4
Capt. Lenny
Born to be Wild
 
Capt. Lenny's Avatar
E-Z-GO
 
Join Date: Feb 2019
Location: Palm Harbor Florida
Posts: 1,460
Default Re: 2006 Star Classic 2+2 issues

At 44.6 volts your batteries are dead. Even 46.04 would be 10% and might make the cart grunt a little. Try using a hydrometer to check the cells.
Capt. Lenny is offline   Reply With Quote
Old 07-30-2022, 09:43 AM   #5
hardhouseinc
Getting Wild
 
Join Date: May 2022
Posts: 78
Default Re: 2006 Star Classic 2+2 issues

yup could be all or one bad battery.
if they are very old or have sat for years not charged they are shot
flooded batteries that arent kept charged will go bad then not charge.
hardhouseinc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
Motor issue-2006 Bad Boy Buggy Classic Electric golf carts
2006 Star Electric golf carts
2006 FairPlay turned out to be a Star Electric golf carts
2006 desert classic ss? Electric Yamaha
2006 Bad Boy Buggie Classic Front End Differential Electric EZGO


All times are GMT -5. The time now is 01:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.