lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-28-2011, 11:07 PM   #1
RSWrestler
Not Yet Wild
 
Join Date: Mar 2011
Posts: 6
Default I Eat Batteries!

To whomever can help:
I've started throwing parts at the problem, and while some may have helped, the problem remains:

My EZGO ST Express blows right through starter batteries in less than a day!

I pulled the fuses on all of the accessories.

I put in a new starter/generator.

I put in a new voltage regulator.

I changed out the negative battery terminal.

What's left?
Change the key switch?
Change Starter solenoid?

I just can't figure this one. I'm about to pull all of the wires on it, and just re-do them 1 by 1~!

If anyone can tell me where to measure for a drain/short, let me know where to start.

Thanks in advance, Everyone!
RSWrestler is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-29-2011, 03:10 AM   #2
IDIeselman
Getting Wild
 
IDIeselman's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: Ludington MI
Posts: 123
Default Re: I Eat Batteries!

Welcome to the site. Do you own or have access to a Fluke meter?
IDIeselman is offline   Reply With Quote
Old 08-29-2011, 10:58 PM   #3
jeffrun
Gone Wild
 
Join Date: Apr 2011
Location: Washington State
Posts: 385
Default Re: I Eat Batteries!

your problem sounds like its the solenoid. You will need a multi-meter. Turn ignition off,make sure you have a charged battery. Select dc volts on meter with a range of 20 or higher. Place the black lead on the neg.(-) of batt. Touch the pos lead on each the large terminals of the solenoid, the reading should be 12v on one and 0v on the other. If both read 12v, then the solenoid contacts are closed and thats not right, Now take your pos lead of meter and place on both of the small terminals of solenoid, you should not have any reading on those with the ignition sw.off. If you have a reading then the problem would be the ignition sw or some wire terminated wrong in that circuit.
Normal operation when cart is running, there would be 12-14.5v on both large terminals and 12-13v on one of the small terminals, the other small terminal is ground. These are continous duty solenoids, not like the old ford start auto relay. Sponsors have them.
jeffrun is offline   Reply With Quote
Old 08-30-2011, 10:32 AM   #4
RSWrestler
Not Yet Wild
 
Join Date: Mar 2011
Posts: 6
Default Re: I Eat Batteries!

Thank you very much for your replies, folks~
Yes, I do have a fluke meter. And I will go try what you recommended.

Just for kicks....if either of you live out in chicagoland, I will give you an old G9 to come and get it workin' with me :o)
RSWrestler is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Changed batteries/batteries won't charge Electric Club Car
Recharging Batteries---so charge recognizes batteries!! Electric EZGO
2009 Batteries versus New Batteries Electric Club Car
charger reads, check batteries, and limit use with new batteries! Electric Club Car


All times are GMT -5. The time now is 05:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.