lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-02-2014, 07:45 PM   #21
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

Thanks guys I'll keep you posted, I messed with the float a little, seemed like I had more power going up hill in my backyard, I see that it is now leaking from bowl, so I'm going to fix that, can't tell if it's still leaking from vent? It's dark out, I'll mess with it again Tomorrow after work, thanks for pointing out the pivot point, that's the way I bought it, and never would of known the difference, I'll have to adjust the linkage cause now it's way off, how do you adjust that??

If adjusted properly? Should it never leak gas from vent? Even while going up hill or on bumpy grass? My backyard has a slight hill, and is very bumpy, till it levels out to get to the old level railroad tracks that my kids can ride for a couple miles round trip, that's why I bought the golf cart. I'm still amazed at how Thease things are made, they are like little cars, springs tie rods e.T c., ha! , I thought the golf cart would be more reliable and a little safer than a go cart, pretty neat!! Thanks guys, Im learning alot, hope I can fix this thing, lol.
mjm697 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-02-2014, 08:00 PM   #22
1989Marathon
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

Should never be leaking fuel if set properly. Good luck with it, and keep us posted.
1989Marathon is offline   Reply With Quote
Old 11-02-2014, 08:35 PM   #23
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

I will, thanks.
mjm697 is offline   Reply With Quote
Old 11-03-2014, 02:11 PM   #24
old231
Not Yet Wild
 
old231's Avatar
 
Join Date: Aug 2012
Posts: 56
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

My linkage measures 1 1/4 inches from locking nut to locking nut and it looks like our ends are about the same. Could be close to the distance of the green painted part in your picture. Last, it appears I am using a much lighter spring for the return.
Attached Images
File Type: jpg carb linkage 001.jpg (188.9 KB, 0 views)
old231 is offline   Reply With Quote
Old 11-03-2014, 07:43 PM   #25
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

Thanks for the measurement and pic, I was going to ask for a pic to see if I am missing anything? And they all have some kind of return spring? I'll try to move mine like your picture. I'm still leaking from bowl, could the gasket be made any cheaper, might have to pull carb again to properly secure gasket? I assume that measurement was from the inside of lock nuts, ? Thanks, keep you posted, I replaced a couple ground wires and the top post terminals today, the ground to frame was so frayed I could pull it off. I adjusted float twice so far, and still leaking from vent, hope to try again tomorrow after work, will keep posted, I hope this does the trick..
mjm697 is offline   Reply With Quote
Old 11-04-2014, 05:58 PM   #26
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

Is there anything else other than adjusting the float, that can cause leaking or squirting from vent? I adjusted float several times, still coming out, also my linkage at 1-1/4 is nowhere near normal on mine, how do you properly adjust linkage?? Thanks.
mjm697 is offline   Reply With Quote
Old 11-04-2014, 07:27 PM   #27
old231
Not Yet Wild
 
old231's Avatar
 
Join Date: Aug 2012
Posts: 56
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

I'm wondering if the new location of the fuel pump can be too high above the carb. With the gas line filled and the pump pumping it may be too much for the needle valve to handle. It is fighting the weight of the gas, gravity and the pump. Can you relocate it to a point below the carb?

As to the additional return spring we both have, I added mine so the butterfly would close faster and stop the backfiring. The spring on my carb was just not strong enough. It is the original carb and I replaced enough seals. Your new carbs should have a return spring built in. Are you sure you need the additional spring?
And to the linkage length, I'm not sure, but do know that too strong a spring will mess you up. Try it with out the additional spring if you decide drop the fuel pump lower.
old231 is offline   Reply With Quote
Old 11-04-2014, 08:04 PM   #28
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

Great point, fuel pump is mounted higher than carb, I will move tomarrow, spring is needed, but im wondering if the heavy spring coming from the throttle cable is messed up as well, I'll keep going on the vent leaking issue and start a new thread on properly adjusting the linkage when or if I get threw this? Ha! Thanks..
mjm697 is offline   Reply With Quote
Old 11-08-2014, 04:49 PM   #29
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

What the heck!?!!???? I moved the fuel pump and lines lower than the carb as suggested, but now the carb is getting flooded? I thought it was the carb, so I put another brand new carb on, (this is the 3rd), so it's not the darn float being stuck? When I pull off the line going into fuel pump, it will blow gas and oil Out of the line for a second and it will then run for a minute? When I put hose back on, it will flood the carb again??? When I take gas inlet line off and look at the fuel pump, I do not see gas coming out of the hole to go into engine?? What am I missing?
mjm697 is offline   Reply With Quote
Old 11-08-2014, 04:53 PM   #30
mjm697
Not Yet Wild
 
Join Date: Nov 2014
Posts: 51
Default Re: 89 ezgo, 244cc robin 3pg, 1st (toy)cart issues.

The pic of the hose off elbow, is the line that comes from engine, that's the line when pulled off will spit some gas, then run for a second. When put back on, engine dies and floods, same process eveytime??
Attached Images
File Type: jpg 20141108_163928.jpg (219.2 KB, 0 views)
File Type: jpg 20141108_163942.jpg (223.4 KB, 0 views)
mjm697 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1983 EZGO textron Robin Engine 244CC 2 stroking Pulsar timing issue Gas EZGO
robin 244cc did not much power Gas EZGO
robin 244cc Gas EZGO
1987 ezgo with a robin 244cc motor Gas EZGO
WTB robin 244cc in KY Golf Carts and Parts


All times are GMT -5. The time now is 06:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.