lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-14-2021, 03:16 PM   #101
JPonLKN
Gone Wild
 
JPonLKN's Avatar
E-Z-GO
 
Join Date: Jul 2020
Location: NC
Posts: 594
Default Re: Workhorse and MPT...I have my work cut out for me

Hey guys,
One of the carts I worked on before, the MPT with a Pre-MCI 350 has an issue. The throttle doesn't like to modulate smoothly. Seems like it is all or nothing, whiplash kinda thing. Everything is set up right, and governor spring where it should be so top speed is 15 MPH. Just can't get the throttle to modulate smoothly through the middle of the pedal travel. Any thoughts on what would cause that?

Thanks
JPonLKN is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-14-2021, 03:21 PM   #102
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,852
Default Re: Workhorse and MPT...I have my work cut out for me

Could be something binding or a broken spring. Turn the key off, take the seat off and cycle the pedal to see what it is doing.
kgsc is offline   Reply With Quote
Old 07-14-2021, 03:53 PM   #103
JPonLKN
Gone Wild
 
JPonLKN's Avatar
E-Z-GO
 
Join Date: Jul 2020
Location: NC
Posts: 594
Default Re: Workhorse and MPT...I have my work cut out for me

Quote:
Originally Posted by kgsc View Post
Could be something binding or a broken spring. Turn the key off, take the seat off and cycle the pedal to see what it is doing.
Everything cycles the way it should, no binding...smooth throttle throw from bottom stop to the top, so full range of throttle is there. Governor linkage is correct. Spring return on the carb pulls the throttle linkage back...as does the governor spring. If I were to guess, I would say it is in fuel delivery within the carb....I am not a carb expert, but is there any way to tell what size jets are in it, and compare to what is supposed to be in it? Also, is the jet and tube on top of the carb for midrange? Maybe that could be the culprit? Thoughts?
JPonLKN is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Workhorse needs work... Gas EZGO
Workhorse wont work!!! Gas EZGO
Major work on a workhorse. . . Electric EZGO
Workhorse Fuel Gauge Does Not Work Gas EZGO
1995 workhorse was running great now I have to work the choke. Gas EZGO


All times are GMT -5. The time now is 06:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.