lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Post New Thread  Reply
 
Thread Tools Display Modes
Old 10-28-2021, 09:26 AM   #51
MYCART8A4RE
Getting Wild
 
MYCART8A4RE's Avatar
Club Car
 
Join Date: Nov 2019
Location: Bradenton, Fl
Posts: 98
Default Re: Extreme Team install

I meant that they may have missed some wiring when they opted to remove the meters from the box altogether. Do you have the gauge/meter on your battery box as well or do you have the newer box with no meter? That's what was making me think that since the wiring inside changed that somthing happened with the 12v connections as it appears all the older boxes with the meters have the 12v terminals working
MYCART8A4RE is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 10-30-2021, 10:52 AM   #52
snoop911
Getting Wild
 
snoop911's Avatar
Club Car
 
Join Date: Jul 2011
Location: Miami,Florida
Posts: 117
Default Re: Extreme Team install

1 problem solved and another one appears
why does my battery reader read 100% and my charger read empty (little red light on empty battery picture) ??
Attached Images
File Type: jpg thumbnail_IMG_7191.jpg (203.6 KB, 0 views)
File Type: jpg thumbnail_IMG_7192.jpg (59.5 KB, 0 views)
snoop911 is offline   Reply With Quote
Old 10-30-2021, 12:13 PM   #53
MYCART8A4RE
Getting Wild
 
MYCART8A4RE's Avatar
Club Car
 
Join Date: Nov 2019
Location: Bradenton, Fl
Posts: 98
Default Re: Extreme Team install

Check to see that your wire from the charger is going to the "p" side of the shunt and not the "b"side. This is just a guess as I have the enclosed on board charger and can't see those lights to compare mine.
MYCART8A4RE is offline   Reply With Quote
Old 11-01-2021, 06:33 AM   #54
Beerdude77
Not Yet Wild
Club Car
 
Join Date: Jun 2020
Location: NC
Posts: 32
Default Re: Extreme Team install

Whelp, last night during trick or treating with the kids I had a strange phenomenon occur. A neighbor wanted a ride after hearing about how quick my cart was now. Thus far I have had the speed dial turned all the way up and the accel dial a decent bit below the black "recommended" line on the Navitas one the fly controller. Well I punched it like I have been doing all week since installing it and it took off then immediately slowed down quite a bit as if I had taken my foot off the "gas". I thought, "Well this is odd". So I turned up the accel dial all the way up. Same thing happened. My battery was at around 68% charge on the dash dial that came with the battery, so I don't think charge was an issue. Any clues what happened? This was similar to when the Roypow would shut down under high current draw but at least in this case the cart was still able to move, albeit at a VERY slow pace compared to what it has been doing thus far. I charged the pack overnight and will report back if it is still occurring later.
Beerdude77 is offline   Reply With Quote
Old 11-01-2021, 07:53 AM   #55
fstop
Gone Wild
 
Join Date: Oct 2019
Posts: 597
Default Re: Extreme Team install

Quote:
Originally Posted by Beerdude77 View Post
Whelp, last night during trick or treating with the kids I had a strange phenomenon occur. A neighbor wanted a ride after hearing about how quick my cart was now. Thus far I have had the speed dial turned all the way up and the accel dial a decent bit below the black "recommended" line on the Navitas one the fly controller. Well I punched it like I have been doing all week since installing it and it took off then immediately slowed down quite a bit as if I had taken my foot off the "gas". I thought, "Well this is odd". So I turned up the accel dial all the way up. Same thing happened. My battery was at around 68% charge on the dash dial that came with the battery, so I don't think charge was an issue. Any clues what happened? This was similar to when the Roypow would shut down under high current draw but at least in this case the cart was still able to move, albeit at a VERY slow pace compared to what it has been doing thus far. I charged the pack overnight and will report back if it is still occurring later.
Sounds like the controller was dropping into low voltage / battery mode. You would see a yellow exclamation box if you were looking at the app.

Look at the voltage (real time) when it happens and see what it drops to. Having others in the cart will also cause more drop (more current) under hard acceleration.

The Navitas lithium battery profiles are a mess - I wouldn't use them. I'd modify a few of the lead acid parameters.
fstop is offline   Reply With Quote
Old 11-01-2021, 08:14 AM   #56
MYCART8A4RE
Getting Wild
 
MYCART8A4RE's Avatar
Club Car
 
Join Date: Nov 2019
Location: Bradenton, Fl
Posts: 98
Default Re: Extreme Team install

Quote "[The Navitas lithium battery profiles are a mess - I wouldn't use them. I'd modify a few of the lead acid parameters.]

I'll have to let my brother know about this. He has been getting some weird dips in power intermittently with his set up. Wonder if the lithium profile has something to do with that. Thanks for that bit of info
MYCART8A4RE is offline   Reply With Quote
Old 11-01-2021, 10:09 AM   #57
fstop
Gone Wild
 
Join Date: Oct 2019
Posts: 597
Default Re: Extreme Team install

Quote:
Originally Posted by MYCART8A4RE View Post
Quote "[The Navitas lithium battery profiles are a mess - I wouldn't use them. I'd modify a few of the lead acid parameters.]

I'll have to let my brother know about this. He has been getting some weird dips in power intermittently with his set up. Wonder if the lithium profile has something to do with that. Thanks for that bit of info
Sure thing.

They've had a lot of time to work on this, but have been focused on other things apparently. There are a lot of variables in the many lithium options out there right now, and that's probably a big part of it to be fair to Navitas.

I have had a Roypow (48v nominal, actually ~52v) and currently have a 72v (~80v actual) and while one of the older FW versions seemed to work ok with the Roypow, I can't use any of the 72v lithium profiles that have been included with the last 2 or 3 Navitas FW revisions. All result in a low voltage situation either immediately or any time a load is put on the cart (acceleration etc...). This is irrespective of what you set "system voltage" to.

Anyway, for those who may have issues like what I responded to above, I'd use the standard lead acid profile and just change system voltage to whatever it is with your pack.
fstop is offline   Reply With Quote
Old 11-01-2021, 11:39 AM   #58
MYCART8A4RE
Getting Wild
 
MYCART8A4RE's Avatar
Club Car
 
Join Date: Nov 2019
Location: Bradenton, Fl
Posts: 98
Default Re: Extreme Team install

Makes sense, this is what I had to do with my Altrax controller as they didn't have a profile option for lithium batteries. I got the settings all dialed in and the cart runs great. I'll be sure to pass that info on to my brother.
MYCART8A4RE is offline   Reply With Quote
Old 11-02-2021, 10:09 AM   #59
ousuxndallas
Not Yet Wild
 
ousuxndallas's Avatar
Club Car
 
Join Date: Apr 2015
Location: Texas
Posts: 51
Default Re: Extreme Team install

Quote:
Originally Posted by MYCART8A4RE View Post
Makes sense, this is what I had to do with my Altrax controller as they didn't have a profile option for lithium batteries. I got the settings all dialed in and the cart runs great. I'll be sure to pass that info on to my brother.
If you don't mind, what Alltrax settings did you change, and what settings did you settle on as "ideal"?
ousuxndallas is offline   Reply With Quote
Old 11-02-2021, 10:25 AM   #60
MYCART8A4RE
Getting Wild
 
MYCART8A4RE's Avatar
Club Car
 
Join Date: Nov 2019
Location: Bradenton, Fl
Posts: 98
Default Re: Extreme Team install

Quote:
Originally Posted by ousuxndallas View Post
If you don't mind, what Alltrax settings did you change, and what settings did you settle on as "ideal"?
I'll hook up my laptop and record the settings I have when I get home from work and post them here.
MYCART8A4RE is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car > Lithium Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Extreme team Lithium batteries? All things Lithium
Extreme Team Lithium Batteries All things Lithium
Nothing to see here. Team Tesla Lithium EZGO
07-14 Team Differential Gas Yamaha
Team clutch Gas EZGO


All times are GMT -5. The time now is 03:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.