lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-23-2012, 04:08 PM   #1
stonekn
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2011
Location: Johnsonville, SC
Posts: 14
Default 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

Unsure of exact year, but I know its a '95-'98 model EZ GO TXT with a 295cc Robin EH29C

No matter what I do, the motor bogs down, backfires through the carb & won't move once the engine is under a load when the clutch grabs the drive belt. I can eventually get it up to full throttle in neutral, but when in gear, it barely has enough power to get moving & once I do get it rolling it doesn't seem to want to get up to top speed or full throttle even going downhill.

Below is a list of things I have done already:

Set & re-set the valves about 15 times (both engine hot & cold) at .004", and eventually replaced the valves, springs, and valve seats. (Yes, I properly lapped the valves before installation)

double checked the timing marks (according to the manual, I should line up the key on the cranckshaft with the timing mark, but my model also had what appears to be a timing mark on the cog as well. Do I line up the key or the dot?)

rebuilt the carb twice - it's still spitting fuel out the front of the carb & backfiring. It seems like it may be flooding itself out, but the carb is clean, float is set & there are virtually no adjustments to adjust the fuel air mixture.

replaced the spark plugs with factory recommended plugs

Ignitor, coils & control module are all brand new & I have confirmed that they are producing a big fat blue spark, so I know it's not an ignition issue.

performed compression test on both cylinders - #1 is at 155lbs & #2 is at 144lbs.

I know these engines at a real bear to get right & it's usually an issue with the valves, but I have done everything to spec & still can't get the results I'm looking for. Anyone have any ideas on what I'm doing wrong or haven't tried yet?
stonekn is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-23-2012, 06:45 PM   #2
simple man
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

Here is a link to an engine manual, if your manual is different. This specifically states to line up the crankshaft key with the mark on the engine. I would go by that. The diagram is on page E-11 of the manual.
http://golfcars.ie/manuals/TXT%20Gas%20Engine.pdf
simple man is offline   Reply With Quote
Old 02-23-2012, 06:55 PM   #3
stonekn
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2011
Location: Johnsonville, SC
Posts: 14
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

Thanks Simpleman, I had used the manual as a reference when installing & setting everything last night & made sure the timing marks were at the keyway on the crankshaft.

Still have the same result.
stonekn is offline   Reply With Quote
Old 02-23-2012, 09:14 PM   #4
ez go go
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

Had a similar problem and found that the throttle linkage was not properly adjusted. It was weak and had no torque and found that the linkage tyeing the butterfly to the throttle plate werent moving together properly. Good Luck!
ez go go is offline   Reply With Quote
Old 02-23-2012, 10:54 PM   #5
COURTESYCART
Gone Wild
 
Join Date: Nov 2008
Location: Montgomery, AL
Posts: 1,463
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

gonna say check your linkages. does everything move freely?

also remove the muffler from the engine, try and crank (yes it will be loud). i have seen a few stopped up mufflers in my 3.5 yrs of fooling with carts.

whats your gas condition?
COURTESYCART is offline   Reply With Quote
Old 02-24-2012, 10:45 AM   #6
stonekn
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2011
Location: Johnsonville, SC
Posts: 14
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

The linkage actually makes sense with the issues I'm having & everything else I've tried. The linkages move freely & aren't binding, but I'm sure that doesn't mean they are properly adjusted. The book I have gives all the technical information about engine internals, but no instructions on setting the linkages properly.

Can anyone give me some instructions on the stock adjustment for the linkages?

To EZ go go - The gas is brand new 93 octane with lucas fuel treatment.

To Courtesy cart - I forgot to torque down the muffler to the exhaust manifold, so I basically fired it up without the muffler attached by accident....LOL.... Same results though.
stonekn is offline   Reply With Quote
Old 02-24-2012, 11:17 AM   #7
popatop
Gone Wild
 
popatop's Avatar
E-Z-GO
 
Join Date: Jun 2008
Location: Raytown, Missouri
Posts: 894
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

Welcome to BGW Stone this might help, Good Luck

http://www.buggiesgonewild.com/ezgo-...ntainance.html
popatop is offline   Reply With Quote
Old 02-24-2012, 11:30 AM   #8
simple man
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

One more suggestion, do you have the spark plug wires on the right plugs? Try switching them and give her a go!
simple man is offline   Reply With Quote
Old 02-24-2012, 03:50 PM   #9
stonekn
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2011
Location: Johnsonville, SC
Posts: 14
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

I went home at lunch & checked the plug wires, but they are not able to be removed from the coil & are cut to length, so there's no way to mix them up. Boy was I hoping it was something that simple!

When I got the cart, all of the electrical components had been installed, but they were unable to get it running correctly.

Is it possible that it would run at all if they had possibly installed some wires in the incorrect locations?

I already had the repair manual posted earlier, but I hav been unable to find a good wiring schematic for my model. Does anyone know where I can find one & does anyone have the specs & test procedures for the stock ignition components?
stonekn is offline   Reply With Quote
Old 02-24-2012, 07:44 PM   #10
loflyer2880
Gone Wild
 
loflyer2880's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: florida
Posts: 170
Default Re: 97 TXT 295cc - Tried EVERYTHING - still backfiring and no power!!!

check out the govenor linkage. Sounds like mine when I tried to jack with it for more top end. Good luck bro
loflyer2880 is offline   Reply With Quote
Reply

Tags
backfire, bog down, ez-go, loss of power
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ec25ds Video of backfiring no power need ignition info Gas EZGO
G1 backfiring Gas Yamaha
'77 EZ Go Backfiring Gas EZGO
G1 Backfiring Gas Yamaha
backfiring G9 Gas Yamaha


All times are GMT -5. The time now is 06:08 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.