lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-22-2015, 07:43 PM   #1
grandpa1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default G16 runs for a few seconds then turns off

Hello BGW. G16 is doing something really weird. It will fire up and run for about 15 seconds and then it quits running. The plug is loosing fire for some reason. I got it to run for several mins. Then it shut down again. Why am I looking spark to my plug?
grandpa1 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-22-2015, 09:09 PM   #2
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,441
Default Re: G16 runs for a few seconds then turns off

You need to be looking at the TCI, and by "looking at" i mean "buying from a Yamaha dealer and replacing", not aftermarket Chiner stuff. TCI is not a repairable item, replace.
cgtech is offline   Reply With Quote
Old 07-22-2015, 09:24 PM   #3
grandpa1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: G16 runs for a few seconds then turns off

That's the igniter/ coil thing
grandpa1 is offline   Reply With Quote
Old 07-22-2015, 09:38 PM   #4
1989Marathon
Gone Wild
 
Join Date: Oct 2010
Posts: 6,730
Default Re: G16 runs for a few seconds then turns off

Quote:
Originally Posted by cgtech View Post
You need to be looking at the TCI, and by "looking at" i mean "buying from a Yamaha dealer and replacing", not aftermarket Chiner stuff. TCI is not a repairable item, replace.
G16 doesn't have a TCI or CDI does it? I thought it just had a magneto coil?
1989Marathon is offline   Reply With Quote
Old 07-22-2015, 10:46 PM   #5
dbmachine
Gone Wild
 
dbmachine's Avatar
 
Join Date: Oct 2012
Posts: 1,730
Default Re: G16 runs for a few seconds then turns off

Here ya go:

http://www.approvalpowersports.com/f...98&fveh=175587
dbmachine is offline   Reply With Quote
Old 07-22-2015, 10:47 PM   #6
dbmachine
Gone Wild
 
dbmachine's Avatar
 
Join Date: Oct 2012
Posts: 1,730
Default Re: G16 runs for a few seconds then turns off

Diagram

http://www.approvalpowersports.com/f...e=ELECTRICAL+1
dbmachine is offline   Reply With Quote
Old 07-23-2015, 06:12 AM   #7
grandpa1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: G16 runs for a few seconds then turns off

Is there any kind of test I can do to make sure this is the issue
grandpa1 is offline   Reply With Quote
Old 07-23-2015, 07:00 AM   #8
grandpa1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: G16 runs for a few seconds then turns off

Just got on the cart and it starts right up. What a pain in the tail trying to figure out this gremlin.
grandpa1 is offline   Reply With Quote
Old 07-23-2015, 09:17 AM   #9
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,441
Default Re: G16 runs for a few seconds then turns off

The ignition system is "self contained", and it is designed in a fashion that you have to "force it to stop making spark". It also uses no input power, just a spinning magnet on the flywheel. At the base of the front of the engine, there is a white plug with 2 wires (blue & black, i think), unplug it. This plug is the one that "kills" the coil when the cart is not supposed to be running, and when its unplugged, the cart should have spark whenever the flywheel is spinning. If you can now drive the cart, and have it fail with "no spark", you have a bad TCI for sure.
cgtech is offline   Reply With Quote
Old 07-23-2015, 12:07 PM   #10
grandpa1
Gone Wild
 
Join Date: Mar 2013
Posts: 495
Default Re: G16 runs for a few seconds then turns off

I unhooked the two wire plug and turned it over. I have no fire at all now.blue and dlack wire
grandpa1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 ez go gas cart runs and clutch belt turns in N but not in F or R Gas EZGO
Car runs for few seconds? Electric Yamaha
Battery light on 25 seconds off 5 seconds Electric Club Car
G22 runs 10 seconds Electric Yamaha
Turns over weird, runs for 100yds then dies Gas EZGO


All times are GMT -5. The time now is 08:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.