lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-02-2010, 11:48 AM   #1
blue74010
Not Yet Wild
 
Join Date: Jul 2010
Posts: 3
Default Ez Go PDS electrical issue ?

Hi everyone this is my first time to post on this site. I use this site to help me with the golf carts I work on, appreciate all the info yall post. Ok I wonder if anyone has run across a PDS cart with the issue I have. When you go drive the cart it does fine in fwd and reverse no matter how long you drive it. But when you stop say for a couple of minutes and get back on it the cart won't move in either direction and the solenoid doesn't activate. Now if you flip the run tow /maint. switch to tow/maint. and let it set for around 5 mins. then turn it back to run then it works till the next time you stop for a minute or two then does the same thing won't go until you flip it to tow/main. and let it set. Ok I have switched out the controller and solenoid and it still does the same thing. Any Ideas?
blue74010 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-02-2010, 12:15 PM   #2
LostHusker
Just one day at a time
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,645
Default Re: Ez Go PDS electrical issue ?

Did you switch it with a new controller solenoid? Also make sure all connections are tight by pulling on each one to make sure. What is your pack voltage?
LostHusker is offline   Reply With Quote
Old 08-02-2010, 10:51 PM   #3
rabbitreborn
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,757
Default Re: Ez Go PDS electrical issue ?

the only thing I can think of is a motor on the fritz..... If the field is overheating, it would give the same symptoms. As soon as you let it sit for a bit, the motor cools and runs again.
rabbitreborn is offline   Reply With Quote
Old 08-03-2010, 05:24 PM   #4
blue74010
Not Yet Wild
 
Join Date: Jul 2010
Posts: 3
Default Re: Ez Go PDS electrical issue ?

One thing I forgot to mention in the post is that if the run / tow maint. switch is left in run, no matter how long the cart sets either with the key off or on it still will not go. But if you flip the switch to tow/mint. mode and let it set for little bit you can flip it back to run and the cart runs just fine, until you stop for about a minute regardless if the key is off or on, then it won't run until you do the same process over again. Very weird to troubleshoot, driving me nuts. Its like the tow maint. / run switch circuit is pulling juice when it shouldn't. ??
blue74010 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
electric club car 1987 - electrical issue Electric Club Car
82 ParCar will not run, electrical issue Gas Columbia ParCar
Electrical issue with Melex Melex
87 ez-go 36volt electrical issue (Help) Electric EZGO


All times are GMT -5. The time now is 04:49 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.