lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-02-2022, 05:56 AM   #1
Beabgunz
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2022
Posts: 3
Default 89í Marathon, new parts, no go.

Hi everyone,
A little background. I came across a dirt cheap 89í marathon electric. The following parts are new. Controller (reman), solenoid, potentiometer and the F/R looks new, but I question if itís the right one. Previous owner got some parts. I got the solenoid and potentiometer. Iím running 3 -12v deep cycles on it. I got into it hard. I stripped the motor down, cleaned it up. Tested the motor by jumping it. It turns. I have followed the wiring diagrams that I could find and I believe Iím wired up correctly. Pack voltage of 37v at solenoid, solenoid clicks, no go. I have checked voltages etc with available guide and will post the numbers when I get a chance to write them down. What Iím questioning right now is the potentiometer. The original had one set of wires( black and white) coming out. New one has two sets of wires (black and red). I have noticed on my brothers cart that his F/R switch has a double micro switch on one side and thatís where his extra cable plugs into. Iím lost at this point. Not sure what to check next. Is there a way to jump the cart through the f/r switch to see if it will go? Any advice and direction would be greatly appreciated.
Beabgunz is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-04-2022, 03:59 PM   #2
Beabgunz
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2022
Posts: 3
Default Re: 89í Marathon, new parts, no go.

At the end, I took the forward/reverse switch apart, sanded the studs, worked after I put it all back together. I was told many times that connection issues are notorious on these. Never thought to check these studs since the f/r was new.

Last edited by Beabgunz; 07-04-2022 at 04:03 PM.. Reason: Double post
Beabgunz is offline   Reply With Quote
Old 07-04-2022, 04:02 PM   #3
Beabgunz
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2022
Posts: 3
Default Re: 89í Marathon, new parts, no go.

At the end, I took the forward/reverse switch apart, sanded the studs, worked after I put it all back together. I was told many times that connection issues are notorious on these. Never thought to check these studs since the f/r was newer.
Beabgunz is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Looking for some marathon parts. Golf Carts and Parts
marathon used parts Gas EZGO
91 Marathon Parts Gas EZGO
ez go txt electric parts+ marathon parts Golf Carts and Parts
marathon parts Golf Carts and Parts


All times are GMT -5. The time now is 03:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.