lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-21-2021, 09:32 AM   #1
otowrxv2
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2017
Location: Florida
Posts: 15
Default RXV with Lithium Batteries

Have a 2014 RXV that I converted to Allied Lithium batteries a year ago. I converted to the 50 amp hour batteries. Everything was great till about two months ago when one battery went zero volts with 60% capacity left. Then another battery went to zero volts. I found out that this is the internal BMS system acting like a circuit breaker. Allied replaced the two batteries and then a third battery failed!! Anybody else out there experiencing these failures?
otowrxv2 is offline   Reply With Quote
 
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO > Lithium EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lithium Batteries Electric EZGO
Lithium batteries Electric Club Car
Lithium batteries Electric EZGO
Lithium Batteries Electric EZGO


All times are GMT -5. The time now is 06:44 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.