lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-02-2014, 05:57 PM   #1
cbordea
Getting Wild
 
Join Date: Dec 2011
Location: SE NC
Posts: 78
Default 91 EZGO TXT won't go, solenoid not clicking.

went out the other day and our cart quit working.
I rolled it to the garage and checked all the connections, still no luck.
It sat there a few days and my son jumped on it and it ran fine for a little while (30 minutes) then quit.

I rolled it back outside my garage for a few days and let it sit.
I then went back through making sure all the connections were clean, water levels filled etc and thought I had a loose switch. I tightened that up and the cart would go again. I pulled it into the garage to top off the charge and it wouldn't go.

Usually when you switch the cart on, you can hear a distinct click of the solenoid engaging. When you lightly press the pedal, you can hear a lighter click of the pedal switch.

I do not hear that initial solenoid click like I used to.
I started reading through the diagnostic steps to check the solenoid this afternoon.
I charged the pack on Saturday and went out there to check things out today.
With my cheap analog meter, I get about 37.5 volts on the pack itself.
If I switch the cart on in FWD, I get 37 on the battery side of the solenoid and 35 on the controller side of the solenoid.
I even tried jumping the switch to make sure that was not the problem.
I feel like something is not telling the solenoid to engage but according to the troubleshooting tips the solenoid isn't the problem.

thanks in advance for your help.
cbordea is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-02-2014, 06:50 PM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 70,645
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Before the solenoid gets the signal to engage, that signal goes through 3 other switches. Use the diagram below to trace it out starting at battery main.
Attached Images
File Type: jpg #3 Ezgo marathon controller cart.jpg (170.6 KB, 0 views)
scottyb is offline   Reply With Quote
Old 06-02-2014, 08:20 PM   #3
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 994
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

I suggest you make some measurements on the solenoid to start with. The big terminals will have voltage on both if there is a resistor connected across them.. that is normal. The solenoid is not likely the problem

I am following scottyb's diagram. Just in case you have trouble reading diagrams the small terminals on the solenoid is what makes it click when one side gets B+ and the other side B-. If you get Battery B+ on the small terminal with the orange wire when you set the cart up to go and press the pedal that eliminates your two micro switches and the key switches being the problem. If not you going to have to start at the key switch and work your way through to see where you are missing voltage. On the diagram follow the red line through Key Switch, F-N-R micro switch MS-2 , MS-3 to the solenoid coil small terminal orange wire. The other side of the coil goes to B - on the black wire. Hope this helps. All voltage measured with voltmeter on Battery negative B-

Be careful to protect against sudden cart movement when working on this. Best to put cart rear wheels on jack stands.

Last edited by radioman; 06-02-2014 at 08:51 PM.. Reason: added safety note
radioman is offline   Reply With Quote
Old 06-03-2014, 06:17 AM   #4
cbordea
Getting Wild
 
Join Date: Dec 2011
Location: SE NC
Posts: 78
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

thanks guys, Radioman I'm not too good at reading wiring diagrams so your description helps a lot. When I jump the orange wire I can hear the solenoid click. When I press the pedal the cart will go.

So if I follow things right this means either part of the FNR switch is bad or the microswitch is bad. Is there a way to check either of those switches?
cbordea is offline   Reply With Quote
Old 06-03-2014, 06:47 AM   #5
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 994
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Quote:
Originally Posted by cbordea View Post
thanks guys, Radioman I'm not too good at reading wiring diagrams so your description helps a lot. When I jump the orange wire I can hear the solenoid click. When I press the pedal the cart will go.

So if I follow things right this means either pare of the FNR switch is bad or the microswitch is bad. Is there a way to check either of those switches?
Yes. They should be voltage on both wires on all three switches in the string starting at he key key switch. They are all connected in series so if one is not working the solenoid will not energize. Or you can bypass each one at a time.
radioman is offline   Reply With Quote
Old 06-03-2014, 06:56 AM   #6
cbordea
Getting Wild
 
Join Date: Dec 2011
Location: SE NC
Posts: 78
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

ok, I hopped from the red wire on the micro switch to the orange wire and the solenoid did not engage. This leads me to believe part of the FNR switch is bad. Is that part replaceable or is it all one unit?
cbordea is offline   Reply With Quote
Old 06-03-2014, 08:38 AM   #7
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 994
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Quote:
Originally Posted by cbordea View Post
ok, I hopped from the red wire on the micro switch to the orange wire and the solenoid did not engage. This leads me to believe part of the FNR switch is bad. Is that part replaceable or is it all one unit?
I would feel more comfortable helping you if you would use a voltmeter. One touch with a jumper wire in the wrong place and you going to have more problems. However the test you made at the FNR switch with the jumper indicates the trouble might be the micro switch operated by the pedal. Did you press the pedal when the jumper was in place to see if the solenoid clicked?

Please get a voltmeter.
radioman is offline   Reply With Quote
Old 06-03-2014, 08:40 AM   #8
Sir Nuke
Master of All Things
 
Sir Nuke's Avatar
E-Z-GO
 
Join Date: May 2013
Location: West Columbia, Texas
Posts: 14,462
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Quote:
Originally Posted by radioman View Post

Please get a voltmeter.
after all......they are CHEAP! you can get one at Wal-Mart for about $10 and will do most anything you will ever need it for.

Wal-mart......there are a few to choose from, as little as $8

http://www.walmart.com/search/search...h_constraint=0
Sir Nuke is offline   Reply With Quote
Old 06-03-2014, 09:06 AM   #9
radioman
Gone Wild
E-Z-GO
 
Join Date: Jan 2014
Location: South Georgia
Posts: 994
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Also it is not normal to hear the solenoid click when you turn the key on as you indicated in your original post. The solenoid should not click until you turn the key on and press the pedal. This indicates trouble in the pedal switch. The pedal micro switch should be open until you press the pedal. It is the last link to energizing the solenoid on the positive voltage side. When you get a voltmeter we can better help you. If you going to work on golf carts get one.
radioman is offline   Reply With Quote
Old 06-03-2014, 09:33 AM   #10
cbordea
Getting Wild
 
Join Date: Dec 2011
Location: SE NC
Posts: 78
Default Re: 91 EZGO TXT won't go, solenoid not clicking.

Quote:
Originally Posted by radioman View Post
I would feel more comfortable helping you if you would use a voltmeter. One touch with a jumper wire in the wrong place and you going to have more problems. However the test you made at the FNR switch with the jumper indicates the trouble might be the micro switch operated by the pedal. Did you press the pedal when the jumper was in place to see if the solenoid clicked?

Please get a voltmeter.
hey, I appreciate your help and concern.
I have a voltmeter, I'll use it going forward.
I did another test...
switch is on.
F&R in F
If I connect the neg to the B- and the pos of the meter to the red wire side of the micro switch that feeds from the F&R switch, I get 0 volts even when pressing the pedal.

Wouldn't that mean that part of the the F&R switch is bad?

I just remembered that I pulled the F&R switch off on Saturday day and noticed what looked similar to battery corrosion coming out of the one of the little boxes. This little box is the one that has the wire going to the micro switch.

I'm assuming that is some kind of switch.

I have attached a picture(borrowed from ebay) of the item I am talking about circled in red.
Attached Images
File Type: jpg FNR.JPG (56.1 KB, 0 views)
cbordea is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
solenoid not clicking Electric EZGO
98 EZGO TXT Clicking Solenoid Electric EZGO
1999 EZGO TXT Solenoid Not Clicking Electric EZGO
solenoid not clicking Electric Club Car
Clicking Solenoid Electric EZGO


All times are GMT -5. The time now is 08:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.