lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 03-06-2009, 04:33 PM   #1
timcan11
Not Yet Wild
 
Join Date: Mar 2009
Posts: 1
Default Doesn't move

I have a 94 EZGO Marathon. I took one battery out to let someone borrow. It worked fine before and in his cart, when I put it back in the cart doesn't move??? The light works on it but nothing else??

Stumped
timcan11 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 03-06-2009, 10:44 PM   #2
DR1989
Not Yet Wild
 
DR1989's Avatar
E-Z-GO
 
Join Date: Feb 2009
Location: winnsboro sc
Posts: 70
Default Re: Doesn't move

Welcome 2 bgw. Have you checked to make sure you have it wired properly? If it is you may try charging it up being sure to check the water levels first. Also could you post more details like if the backup alarm work and if the solinoid click when you put it in gear and mash the pedal.
DR1989 is offline   Reply With Quote
Old 03-07-2009, 12:46 AM   #3
rusty
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,236
Default Re: Doesn't move

Hello timcan11 and Welcome to the forum.
rusty is offline   Reply With Quote
Old 03-07-2009, 09:28 AM   #4
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 73,406
Default Re: Doesn't move

Welcome..... my initial thought is the battery is not wired right? But it would still move on 30v so it must be you have disconnected something else? Are the micros and the solenoid clicking?
Check the voltage accross the pack?
scottyb is offline   Reply With Quote
Old 03-07-2009, 11:00 AM   #5
FIXEROFCARTS
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: Doesn't move

If it worked before the change and not after, then its a missed wire.
FIXEROFCARTS is offline   Reply With Quote
Old 03-07-2009, 11:55 AM   #6
scottyb
Happy Carting
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 73,406
Default Re: Doesn't move

Quote:
Originally Posted by FIXEROFCARTS View Post
If it worked before the change and not after, then its a missed wire.
Unless you blew the fuse .....?
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ-GO will not move Electric Club Car
txt will not move Electric EZGO
Will move in R but not in F Electric EZGO
g19 won't move Electric Yamaha


All times are GMT -5. The time now is 08:48 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.