lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-26-2011, 10:40 PM   #1
skratchgolfer
Not Yet Wild
 
Join Date: Apr 2011
Posts: 4
Default Yamaha g9 runs great for 18 then...

Hey guys, great forum. thanks to you guys i got my father in-laws cart running great after sitting for years.

Anyway im still having a slight problem when i get up over 18 holes in a day. when it hits a certain point in the day after hitting a tee shot and coming back to go chase it, it stalls and doesn't want to fire. i have to feather the gas pedal to get it to turn over. after it gets going finally it runs great. im wondering if it does it when it gets real hot? or if it has something to do with spark?

At the beginning of the season i changed all oil, filter, fuel filter, vacumm lines, and spark plug. i also cleaned the carbs and everything out. also got the the straps for the airbox and is all tight. I know its not a fuel issue because i have an inline fuel filter and gas is pumping through it. not sure what to do

do i need to change plug wires? and where can i get the wires on the web? any help is appreciated. thanks guys!
skratchgolfer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-27-2011, 12:47 AM   #2
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,777
Default Re: Yamaha g9 runs great for 18 then...

You can't change the plug wire, they are permanently attached to the coil.

Often when the car won't run when warm the cdi is the problem. But their expensive! Test other electronics first. You can't test cdi.
Mike Mac is offline   Reply With Quote
Old 05-27-2011, 06:28 AM   #3
traceman
Gone Wild
 
traceman's Avatar
Yamaha
 
Join Date: Sep 2009
Location: Huntsville, AL
Posts: 157
Default Re: Yamaha g9 runs great for 18 then...

Wait!!! You are using this on a golf course?? I thought they were for jacking up and crushing go-carts. At least in my neighborhood they are. LOL

Sorry couldn't resist!
traceman is offline   Reply With Quote
Old 05-27-2011, 06:57 AM   #4
sho305
Vegas modded 420
 
sho305's Avatar
Yamaha
 
Join Date: Jun 2009
Location: West MI
Posts: 15,325
Default Re: Yamaha g9 runs great for 18 then...

Mine will do this when its really warm out and I have the same guess about the ignitor. I'm going to borrow the one out of the clone I did and see if it changes mine. Possible its a valve sticking too. I did clean my cooling fins and it helped they had dirt in them. If the top rocker cover leaks oil it will fill the fins with dirt and plug them. Yes ignitor is pricey for sure. See the timing is advanced about 30 degrees all the time, at low rpm under 2500 the ignitor retards the timing to near 0 degrees at start and ramps up. So I think it stops doing that or something because mine will run ok if I hold it on the floor and get the rpm up, then it cools some and is ok. The odd thing is I've run for a bit then it starts missing and bogging for a ways then stopped doing it, and I went miles after that with no problem....going down the same road and same speeds.
sho305 is offline   Reply With Quote
Old 05-27-2011, 07:02 AM   #5
Dlcain
Gone Completely Insane
 
Dlcain's Avatar
Yamaha
 
Join Date: Apr 2011
Location: Eaton Rapids, Michigan
Posts: 390
Default Re: Yamaha g9 runs great for 18 then...

LOL Traceman! Me and my neighbor are already having goft cart race's in our back yard (3 arcres).... His EZ-go gets me in the corners, but I can get him down the back straight!
Dlcain is offline   Reply With Quote
Old 05-27-2011, 08:04 AM   #6
skratchgolfer
Not Yet Wild
 
Join Date: Apr 2011
Posts: 4
Default Re: Yamaha g9 runs great for 18 then...

Thanks Mike and Sho,

Is there a thread that shows you exactly how to test all the electronics? I'm not exactly a whiz kid with electric components.? Could it possibly be the ignition coil or no chance? Thanks again.
skratchgolfer is offline   Reply With Quote
Old 05-27-2011, 08:22 AM   #7
bigstik40
Gone Wild
 
bigstik40's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Erie, Pennsylvania
Posts: 989
Default Re: Yamaha g9 runs great for 18 then...

I know you said you don't suspect a fuel issue, but just wondering here if the fuel pump could be weak. You say problem starts after 18 holes of golf. Could it be that when gas gets low in tank, then fuel pump has trouble pumping fuel. This is just a WAG but would be easy to check. Good luck. - RAY
bigstik40 is offline   Reply With Quote
Old 05-27-2011, 08:40 AM   #8
skratchgolfer
Not Yet Wild
 
Join Date: Apr 2011
Posts: 4
Default Re: Yamaha g9 runs great for 18 then...

The tank is nearly full, thanks for the thought though!
skratchgolfer is offline   Reply With Quote
Old 05-27-2011, 08:48 AM   #9
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,777
Default Re: Yamaha g9 runs great for 18 then...

Quote:
Originally Posted by traceman View Post
Wait!!! You are using this on a golf course?? I thought they were for jacking up and crushing go-carts. At least in my neighborhood they are. LOL

Sorry couldn't resist!
Ya, what's 18 holes??? Do you know less than 5% of golf carts are used on golf courses! WHY do they call them GOLF CARTS?

I took my componets to the local cart shop to have them tested, They said "at this time" everything is working, it is probably the CDI. It was!
Mike Mac is offline   Reply With Quote
Old 05-27-2011, 09:07 AM   #10
skratchgolfer
Not Yet Wild
 
Join Date: Apr 2011
Posts: 4
Default Re: Yamaha g9 runs great for 18 then...

Thanks Mike,

If I were to bring all the components into the shop, what all should I be bringing? Sorry for the noooob question, but I appreciate your response!
skratchgolfer is offline   Reply With Quote
Reply

Tags
spark, stalls
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Runs great sometimes and others won't take off for 4 or 5 min. Gas EZGO
Runs great wont move!!! Gas Club Car
Runs great in reverse!!!! Gas EZGO
88 G2 Gas. Runs great sometimes. Gas Yamaha
Fe 290 runs great then smokes then great?? Gas Club Car


All times are GMT -5. The time now is 03:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.