lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 09-22-2010, 03:57 PM   #1
rltcmp
Not Yet Wild
 
Join Date: Sep 2010
Posts: 6
Default 1997 ezgo electric golf cart

my cart had been running ok then when I went to accelarate it was as if it would not go into gear. It has a sound of like a plastic gear is not engaging to turn the wheels. Can anyone advise me on what I need to do? This is not a battery problem, they are charged. thanks
rltcmp is offline   Reply With Quote
Old 09-22-2010, 04:08 PM   #2
rib33024
......................
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 16,112
Default Re: 1997 ezgo electric golf cart

Welcome to BGW

can you listen closer to the noise and figure out where it is coming from, it sounds like a striped brake drum on the read axle?
rib33024 is offline   Reply With Quote
Old 09-22-2010, 04:30 PM   #3
rltcmp
Not Yet Wild
 
Join Date: Sep 2010
Posts: 6
Default Re: 1997 ezgo electric golf cart

sounds more like from the middle of the axile, but I am courious about your response on how that would have anything to do with it not engaging, the brakes are not locked up, thanks for the reply.
rltcmp is offline   Reply With Quote
Old 09-22-2010, 05:01 PM   #4
rib33024
......................
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 16,112
Default Re: 1997 ezgo electric golf cart

Ezgo's are known for striping out the brake drum,--the axle has a spline on it that the brake drum fits on to drive the the cart, and it strips out, an easy way to check it is to, jack up the cart put it on jack stands, pull the wheel off and remove the center cap so you can see the castle nut that holds the drum on the axle,have some one ut there foot on the brake and then push the go pedal just a little, while you look at that nut and see if it is spinning, and the drum is not.
But if you think it is coming from the center where the motor hook up to the rear end, you need to pull the motor off and see whats up in there



O and Welcome to BGW
rib33024 is offline   Reply With Quote
Old 09-23-2010, 08:32 AM   #5
COURTESYCART
Gone Wild
 
Join Date: Nov 2008
Location: Montgomery, AL
Posts: 1,463
Default Re: 1997 ezgo electric golf cart

I have seen the collar from the motor to input shaft of diff strip, but its very uncommon.

I would have 2 agree with RIB. It sounds like you have a stripped hub/brake drum. If you replace them make sure you torque that castle nut to atleast 80 ft lbs. Also do not back off the nut to put in cotter pin, keep tighting until the pin goes in.
COURTESYCART is offline   Reply With Quote
Old 09-23-2010, 08:39 PM   #6
rltcmp
Not Yet Wild
 
Join Date: Sep 2010
Posts: 6
Default Re: 1997 ezgo electric golf cart

where is the spline located?
rltcmp is offline   Reply With Quote
Old 09-23-2010, 09:21 PM   #7
rib33024
......................
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 16,112
Default Re: 1997 ezgo electric golf cart

the spline is on the end of the axle, and the in side of the drum, where the drum slides on the axle, it's hard to see in the pic but rite there on the end of the axle.--at the bottom of the pic





rib33024 is offline   Reply With Quote
Old 09-24-2010, 10:23 AM   #8
rltcmp
Not Yet Wild
 
Join Date: Sep 2010
Posts: 6
Default Re: 1997 ezgo electric golf cart

the spline on the right side axle is worn out on the hub, the other is ok, however the noise that I hear is coming from the motor area. The rear axle will turn (both sides) when i run the motor, however, it is not engaged because I can hold the axle and it just spins. and suggestions where to start on this? thanks for your help.
rltcmp is offline   Reply With Quote
Old 09-24-2010, 08:06 PM   #9
rltcmp
Not Yet Wild
 
Join Date: Sep 2010
Posts: 6
Default Re: 1997 ezgo electric golf cart

RIB......thanks for the help, I'm back up and running the fairways. Your info was very helpful. Thanks again.
rltcmp is offline   Reply With Quote
Old 09-24-2010, 08:48 PM   #10
todo_brane_ded
.....He, not ME
 
todo_brane_ded's Avatar
E-Z-GO
 
Join Date: Sep 2010
Location: Spring Hill, FL
Posts: 390
Default Re: 1997 ezgo electric golf cart

Quote:
Originally Posted by rltcmp View Post
RIB......thanks for the help, I'm back up and running the fairways. Your info was very helpful. Thanks again.
Um, so if it wasn't the spline what was the problem?????
todo_brane_ded is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
ezgo electric golf cart Electric EZGO
1995 ezgo electric golf cart Electric EZGO
1995 electric ezgo golf cart Electric EZGO
1997 ezgo txt electric cart quit running need help Electric EZGO


All times are GMT -5. The time now is 03:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.