lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 11-11-2020, 03:33 PM   #1
reidedenfield
Not Yet Wild
 
Join Date: Mar 2018
Posts: 8
Default EZGO PDS XCT Controller not powering on

Hello
I have a EZGO PDS with a Alltrax XCT 400 controller that is not powering on unless hooked to my computer via usb. When I hook it to my laptop it will power on and I get three error codes. Shutdown, high throttle input underrange and low throttle input underange. I believe this is due to the controller not getting the correct input power to turn on from the cart. I have checked all the voltages at the C1 connector based off some other threads and i am not getting voltage at Pin 9. Any ideas on why I wouldn’t be getting voltage at pin 9? Based on the alltrax software on my laptop my key switch works, and F/R switch works. Could it be something internal to the controller? Thanks for your help in advance
reidedenfield is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 11-11-2020, 04:54 PM   #2
scottyb
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 70,651
Default Re: EZGO PDS XCT Controller not powering on

I power up controllers on my desk all day long and they do not throw fault codes. So Do you have power to pins 4 and 9 with the key on at connector C1?
scottyb is offline   Reply With Quote
Old 11-11-2020, 06:22 PM   #3
reidedenfield
Not Yet Wild
 
Join Date: Mar 2018
Posts: 8
Default Re: EZGO PDS XCT Controller not powering on

The controller is in the cart and worked fine up until this week. What I meant is that the led indicator light does not power on at all via key switch of the cart. The only way I can get the led light indicator to show any power is by hooking it into my computer. With the key on I have voltage on pin 4 but not at pin 9. I have attached a picture of my error codes.
Attached Images
File Type: jpg 7487B81E-B248-41B8-B64E-1AFBE3DE7B07.jpg (216.0 KB, 0 views)
reidedenfield is offline   Reply With Quote
Old 11-11-2020, 06:33 PM   #4
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 18,833
Default Re: EZGO PDS XCT Controller not powering on

Quote:
Originally Posted by reidedenfield View Post
Hello
I have a EZGO PDS with a Alltrax XCT 400 controller that is not powering on unless hooked to my computer via usb. When I hook it to my laptop it will power on and I get three error codes. Shutdown, high throttle input underrange and low throttle input underange. I believe this is due to the controller not getting the correct input power to turn on from the cart. I have checked all the voltages at the C1 connector based off some other threads and i am not getting voltage at Pin 9. Any ideas on why I wouldn’t be getting voltage at pin 9? Based on the alltrax software on my laptop my key switch works, and F/R switch works. Could it be something internal to the controller? Thanks for your help in advance
The two red highlighted statements are mutually exclusive. Pin-9 has to have voltage on it or the Toolkit monitor screen wouldn't indicate the keyswitch as working.

You are measuring the voltage on C1 with the cable plugged into the XCT?

Also, is C4 plugged in?
JohnnieB is offline   Reply With Quote
Old 11-11-2020, 06:36 PM   #5
reidedenfield
Not Yet Wild
 
Join Date: Mar 2018
Posts: 8
Default Re: EZGO PDS XCT Controller not powering on

things I have checked. Battery’s are charged, reed switch is good, continuity check was successful on the controller, have pack voltage on every pin on C1 that should show voltage except pin 9. Pin 9 has 0 voltage.
reidedenfield is offline   Reply With Quote
Old 11-11-2020, 06:39 PM   #6
reidedenfield
Not Yet Wild
 
Join Date: Mar 2018
Posts: 8
Default Re: EZGO PDS XCT Controller not powering on

C4 is plugged in, and voltage readings were taken from the back side of the connector with it plugged into the XCT controller. I did not have it hooked into my computer when I took the voltage readings
reidedenfield is offline   Reply With Quote
Old 11-11-2020, 07:43 PM   #7
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 18,833
Default Re: EZGO PDS XCT Controller not powering on

What continuity check did you use?
The voltage feed-throughs are different on a XCT-PDS than the are on a stock PDS controller.

(XCT continuity check attached)
Attached Files
File Type: pdf XCT-PDS CONT-CHECK.pdf (752.3 KB, 0 views)
JohnnieB is offline   Reply With Quote
Old 11-11-2020, 08:24 PM   #8
reidedenfield
Not Yet Wild
 
Join Date: Mar 2018
Posts: 8
Default Re: EZGO PDS XCT Controller not powering on

Yep that’s the one I used.
reidedenfield is offline   Reply With Quote
Old 11-12-2020, 11:17 AM   #9
JohnnieB
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 18,833
Default Re: EZGO PDS XCT Controller not powering on

Using that check list and backtracking to the voltage source of C1 Pin-9, I come up with C1 Pin-5 instead of J1 (Called C1 on a XCT) Pin-4 like it is on a stock PDS controller, you said all the pins on C1 had the proper voltages.

Have you contacted Alltrax? Maybe they'll be able to shed some light.
JohnnieB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
New controller not powering up Electric EZGO
New alltrax controller worked fine then no reverse and now not even powering up. Electric EZGO
Problem with Alltrax Speed Controller Powering Up Electric Club Car
AXE controller not powering up Electric Club Car
EZGo TXT DCS Controller is not powering on Electric EZGO


All times are GMT -5. The time now is 07:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.