lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-21-2020, 10:02 PM   #1
Dave Barton
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2018
Location: Magnolia, TX
Posts: 27
Default 2008 ezgo rxv no go

ezgo rxv stopped on golf course, does nothing when key is turn
ed, no start up procedure, no solenoid click, and no lights, only gauge moves to full when key is turned. Replaced solenoid and no difference. Help if you can. Thanks
Dave Barton is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-22-2020, 07:00 AM   #2
wingnut2000
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 446
Default Re: 2008 ezgo rxv no go

this seems to be happening to a lot of RXV owners the last couple of weeks. mine is a 2015 and did it in the middle of the road in my neighborhood but mine was due to corrosion to some wires going to main battery positive terminal causing loose connections.
wingnut2000 is offline   Reply With Quote
Old 07-22-2020, 07:14 AM   #3
Dave Barton
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2018
Location: Magnolia, TX
Posts: 27
Default Re: 2008 ezgo rxv no go

I have removed and re-tightened the battery cables. the crazy thing is, the lights, turn signals, and horn don't work, along with no solenoid click or motor brake procedure at start up. I even swapped out the ignition switch with another known working cart and no change
Dave Barton is offline   Reply With Quote
Old 07-22-2020, 07:36 AM   #4
wingnut2000
Gone Wild
 
wingnut2000's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Georgia
Posts: 446
Default Re: 2008 ezgo rxv no go

yea my horn and lights didnt work either and battery gauge was giving strange readings. could be solenoid but let the tech guys come along for better info.
wingnut2000 is offline   Reply With Quote
Old 07-22-2020, 07:45 AM   #5
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,952
Default Re: 2008 ezgo rxv no go

Did you check for pack voltage at the main posts? If there check the blue wire coming off the charger port for pack + voltage. Also check the fuses next to the body in front of the controller
kgsc is offline   Reply With Quote
Old 07-23-2020, 07:41 AM   #6
Dave Barton
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2018
Location: Magnolia, TX
Posts: 27
Default Re: 2008 ezgo rxv no go

Pack voltage 50.1 All fuses good. Pack voltage at solenoid big terminal and small terminal with key on. This cart had been shutting off occasionally and restarting after sitting for a few minutes. we figured the solenoid was getting hot and sticking. I had already gotten a solenoid for it when it quit this time.
Dave Barton is offline   Reply With Quote
Old 07-23-2020, 07:58 AM   #7
kgsc
Gone Wild
 
kgsc's Avatar
Mixed Breed
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 9,952
Default Re: 2008 ezgo rxv no go

The early rxv solenoid was trash and most were replaced with a better model. Replace it with the newer model at least.
kgsc is offline   Reply With Quote
Old 07-23-2020, 08:08 AM   #8
Dave Barton
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2018
Location: Magnolia, TX
Posts: 27
Default Re: 2008 ezgo rxv no go

the solenoid is a trombetta which i replaced with the same. I am thinking there has to be a wire broken somewhere or maybe something else which can overheat. There is a module on the heat sink which has 3 wires going to it which I dont know what it is. I keep going back to the fact the lights are no longer working either

Last edited by Dave Barton; 07-23-2020 at 08:14 AM.. Reason: Need to add content
Dave Barton is offline   Reply With Quote
Old 07-23-2020, 12:04 PM   #9
Dave Barton
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2018
Location: Magnolia, TX
Posts: 27
Default Re: 2008 ezgo rxv no go

does anyone know if the voltage converter on the drivers side goes out, will that cause the cart to not run? I get no power out on the converter.
Dave Barton is offline   Reply With Quote
Old 07-23-2020, 12:54 PM   #10
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,441
Default Re: 2008 ezgo rxv no go

Quote:
Originally Posted by Dave Barton View Post
the solenoid is a trombetta which i replaced with the same. I am thinking there has to be a wire broken somewhere or maybe something else which can overheat. There is a module on the heat sink which has 3 wires going to it which I dont know what it is. I keep going back to the fact the lights are no longer working either
Resistor control module, it will shut down the cart if it fails. Easy diagnostics for it are in the RXV troubleshooting guide.
cgtech is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ezgo gas txt 2008 Gas EZGO
.? B4 I my a 2008 ezgo rxv Gas EZGO
2008 Club Car Precedent vs. 2008 ezgo pds Electric Club Car
2008 Club Car precedent vs. 2008 ezgo pds Electric EZGO
Ezgo 2008 Electric EZGO


All times are GMT -5. The time now is 02:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.