lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-15-2020, 12:08 PM   #1
Stewbuntu
Getting Wild
E-Z-GO
 
Join Date: Apr 2018
Posts: 93
Default New voltage regulator and starter, battery voltage drops when running

I put in a new voltage regulator to see if that was my problem and have a spare if not. Now I have a new starter generator and a new voltage regulator in the cart.

I charged my battery. It was 13.11 and I drove it around went to 12.65 so rather than run around to see if it goes under 12.6 I thought I would put it in neutral and start it up and see what the voltage on the battery did. It went from 12.65 down to 11.8 - so I have a voltage drop when the starter generator is running.

I read about that in a post somewhere, but couldn't find it again anywhere to see what was wrong.

Update on testing:
11.8v off the starter on the A1 positive post and meter neg to negative battery post.

Voltage across the starter relay

Inline fuse in the picture in the same area ohms out

After testing things w the meter and unplugging the green and red wire plug, now the battery was 12.74v

With the green and red plugged in the voltage was 11.94 wot in nuetral

Unplugged battery voltage was 12.49v wot in neutral
Unplugged

Shouldn't I be getting 14v on the generator?



Sent from my phone using Tapatalk
Stewbuntu is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-15-2020, 12:51 PM   #2
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,441
Default Re: New voltage regulator and starter, battery voltage drops when running

Many aftermarket starter/generators had the red & green wires flipped internally. Try disassembling that plug & swapping the wires. Bet that'll get ya going. Just one of the many problems I have encountered with aftermarket starter/generators.
cgtech is offline   Reply With Quote
Old 06-15-2020, 02:36 PM   #3
Stewbuntu
Getting Wild
E-Z-GO
 
Join Date: Apr 2018
Posts: 93
Default Re: New voltage regulator and starter, battery voltage drops when running

Quote:
Originally Posted by cgtech View Post
Many aftermarket starter/generators had the red & green wires flipped internally. Try disassembling that plug & swapping the wires. Bet that'll get ya going. Just one of the many problems I have encountered with aftermarket starter/generators.
Where do I get a new oem one? It's Hitachi right?


Swapping won't damage anything? Can I test red vs green somehow first?

Were is the post on how to test the green wire and the sequence. I saw the "not starting" sticky.

Do you test green disconnected and neg of battery and get 17 volts.

Update- I'll try this https://www.youtube.com/watch?v=IFnBaSLbRkQ

Saga continues:
The alternator repair shop guy was wierd and elusive. He said my oem isn't putting put many amps after he finally tested it. he said there is no way for him to know if it's can be fixed unless he takes it apart and it's $160 to rebuild alternator. I said if I just put new brushes in it and the bearings are smooth what else would you be doing and he said went into how long it would take to take it apart. I think he just likes to work on alternators and swap brushes and bearings out and make a quick hundred fifty bucks because I asked him if he could repair the windings or swap out an armature and he said , "I can't compete with the internet." That made no sense to me, if you can buy an armature and install it in a customer's starter then why wouldn't you make money off that? He also said they don't put out 17 volts and some other stuff that didn't make sense. He said it was a 12v system. I mentioned I thought that the voltage regulator was what decrease the voltage down has a pulse is at 17 volts in a golf cart and he said well I'll just go test it.

So I'm taking it to another shop that said they would do a little more extra work and look at the posts and some other stuff inside and there are about 80 different SGs so he could get a armiture after he saw it

Sent from my phone using Tapatalk
Stewbuntu is offline   Reply With Quote
Old 06-15-2020, 03:03 PM   #4
cgtech
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 17,441
Default Re: New voltage regulator and starter, battery voltage drops when running

Or you could just try my suggestion & be done with it.
cgtech is offline   Reply With Quote
Old 06-15-2020, 03:15 PM   #5
Stewbuntu
Getting Wild
E-Z-GO
 
Join Date: Apr 2018
Posts: 93
Default Re: New voltage regulator and starter, battery voltage drops when running

Quote:
Originally Posted by cgtech View Post
Or you could just try my suggestion & be done with it.
I'll try it and if it works I'll have a spare. Just ordered oem SG and voltage regulator along with my needed clutch rollers from plowman's. I'm done tinkering. I like tinkering to increase HP speed etc not to get it working. If the aftermarket doesn't work after the wire swap I will send it back to Amazon and just have all new oem anyways.

I have mounted the SG in that thing like 4 times. It was charging fine but didn't start well so I changed the brushes and it stopped charging afterwards but starts well. Go figure.

Attempts:
1.) Took out to add new New brushes and put it back in
2.) New after market arrived didn't work, might have been the voltage reg tho. Took it back out and returned
3.)Put old one back in with new brushes, it didn't charge
4.)got a voltage reg and new SG encase it was the regulator, and those didn't work today.
Now I'll have to take out the aftermarket one when the OEM arrives.

It's getting old



Sent from my phone using Tapatalk
Stewbuntu is offline   Reply With Quote
Old 06-15-2020, 07:07 PM   #6
Golf cart guy
Gone Wild
 
Golf cart guy's Avatar
 
Join Date: May 2015
Location: Central Florida
Posts: 2,015
Default Re: New voltage regulator and starter, battery voltage drops when running

Chances are good there is nothing wrong with your original. Scrap the aftermarket crap, put your original stuff back in. then start to figure it out. Super super rare the voltage regulator goes bad, so put that back in. Its not that hard to figure out the charge system on these carts. Don't create your own problem.
Golf cart guy is offline   Reply With Quote
Old 06-16-2020, 04:09 PM   #7
Stewbuntu
Getting Wild
E-Z-GO
 
Join Date: Apr 2018
Posts: 93
Default Re: New voltage regulator and starter, battery voltage drops when running

Quote:
Originally Posted by cgtech View Post
Many aftermarket starter/generators had the red & green wires flipped internally. Try disassembling that plug & swapping the wires. Bet that'll get ya going. Just one of the many problems I have encountered with aftermarket starter/generators.
Yep the wires were flipped. Thank you

Got 13.91 while at wot in neutral. Drove it for about 5 minutes and it went from 12.57 to 12.99 on the battery. So now I know everything works, and that something is wrong with the OEM starter. I have a oem starter and VR coming in the mail so this will keep me running for a few weeks and can be my backup when the mail arrives and I swap in the new oem.

Again, Thanks Cgtech

Sent from my phone using Tapatalk
Stewbuntu is offline   Reply With Quote
Old 04-30-2021, 07:30 AM   #8
kmagnuss
Not Yet Wild
 
Join Date: Nov 2019
Posts: 3
Default Re: New voltage regulator and starter, battery voltage drops when running

Guys thanks so much for this thread. I've been chasing my tail on this **** thing for 6 months, replacing darn near everything electrical, wires, grounds, switches, motor, VR, solenoids, etc, etc...
I realized when I adjusted the screw on my VR in I was actually losing voltage instead of gaining it, and this thread made me realize the aftermarket SG's sometimes have the red/green wires switched. Crazy.

Anyhow... thanks again for saving me from burning it down to the ground.

-Mag
kmagnuss is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Is this a starter/gen issue or voltage regulator Gas Club Car
Voltage Regulator or Starter Generator Gas EZGO
Ez go starter generator and voltage regulator question Gas EZGO
Voltage Regulator or Starter /Gen Bad? Gas EZGO
battery voltage drops within an hour Electric Club Car


All times are GMT -5. The time now is 03:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.