lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-30-2009, 10:29 PM   #1
MTNBOATER
Not Yet Wild
 
Join Date: May 2007
Posts: 8
Default 98 EZGO no Elect. power possibel relay/fuse.

Tonight I pulled my cart into the garage and it died - it has no power to the starter or headlights. It started in my driveway and drove fine, but when I was pulling into it's spot slowly, on starter /generator power, she just stopped. I checked the battery terminals and the battery seems to have juice. My headlights normally work with the ignition on or off so it seems like a relay or fuse may have gone. I checked 1 small fuse at the relay/starter solinoid block next to the battery. As I said I can not get the headlights to come on at all and they are wired direct to the battery. No power to the starter generator when I hit the gas peddle. The back up alarm does activate when reverse is engaged.

Is there a relay or fusable link that I'm not seeing?

Maybe the battery died, and my cheap Multimeter is giving me a bad signal.
Cart is stock 9 HP with a lift and dirt tires.

Thanks
MTNBOATER is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-30-2009, 10:48 PM   #2
tonyton
Gone Wild
 
tonyton's Avatar
E-Z-GO
 
Join Date: Jan 2009
Location: Alabama
Posts: 2,120
Default Re: 98 EZGO no Elect. power possibel relay/fuse.

Clean you battery ground first. A bad ground, some things will operate some will not and the battery will be good. Remove the bolts and clean the mating surfaces. It should be grounded at the frame, starter/gen and motor. They corrode, rust and get dirty preventing a good ground. Be sure your battery cable connections are in good condition.
Let us know what happens.
tonyton is offline   Reply With Quote
Old 07-01-2009, 10:24 AM   #3
MTNBOATER
Not Yet Wild
 
Join Date: May 2007
Posts: 8
Default Re: 98 EZGO no Elect. power possibel relay/fuse.

I will clean the grounds today and post back up tonight Tonyton.

Thanks
MTNBOATER is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Relay on Timer Board Power Wise Electric EZGO
Power Relay? Electric Club Car
G1 blowing relay fuse Gas Yamaha
Help with Elect. EZGO! Electric EZGO
First Post - HELP! w/elect EZGo Electric EZGO


All times are GMT -5. The time now is 02:24 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.