lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 02-22-2010, 10:44 AM   #1
Nosloturbo
Not Yet Wild
 
Join Date: Jun 2009
Posts: 10
Question 2004 jerky clutch slip feel at slow accel. now no go.

Thanks in advance for help. My 2004 had a jerky slipping clutch feel at slow accelleration from a dead stop for a few days and now it wont move. If you punched it it would take off no prob. I'm thinking it's the motor. Guess thats why they sold it. lol. I saw the sticky post to test the motor, controller, ect. and will test tonight. Just wondering if someone more knowledgeable than myself could point me in the rite direction.
Thanks again.
Nosloturbo is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 02-22-2010, 01:29 PM   #2
COURTESYCART
Gone Wild
 
Join Date: Nov 2008
Location: Montgomery, AL
Posts: 1,463
Default Re: 2004 jerky clutch slip feel at slow accel. now no go.

could be a bad battery or cable. a weak/bad battery will cause an electirc cart to shutter when moving slow.
COURTESYCART is offline   Reply With Quote
Old 03-03-2010, 09:55 PM   #3
Nosloturbo
Not Yet Wild
 
Join Date: Jun 2009
Posts: 10
Default Re: 2004 jerky clutch slip feel at slow accel. now no go.

Ok sorry for the delay, but I melted my wedding ring to my finger while cleaning the battery terminals. Now that I can work on it again here's what i've got.
I cleaned all battery terminals. "note to self, remove wedding ring next time."
The soleniod clicks when the gas pedal is pressed so I jumped the 2 big terminals with a 6 ga. wire and still no go.
I fully charged the batteries and get 6.4+ volts at all batteries, 38.7 volts total.
Checked the voltage at the solenoid and it matches the battery pack.
Checked the voltage at the 6 pin connector on top of the controller red, white, and black wires and all passed voltage tests as specified in the how to sticky.

Not to sure what to do next. Any help is greatly appreciated as my kids are really getting pissed. LOL

Also it's an 04 ezgo TXT model.

Thanks, Jeff
Nosloturbo is offline   Reply With Quote
Old 03-12-2010, 08:49 AM   #4
Nosloturbo
Not Yet Wild
 
Join Date: Jun 2009
Posts: 10
Exclamation Re: 2004 jerky clutch slip feel at slow accel. now no go.

any help please!
Nosloturbo is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric Club Car 1996 drive slipping on accel Electric Club Car
94' ezgo reverse only w/ out accel Electric EZGO
2004 DS 36V Slow uphill Electric Club Car
2004 Club Car is slow Electric Club Car


All times are GMT -5. The time now is 12:02 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.