lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-03-2010, 04:53 PM   #1
brad1161
Not Yet Wild
 
Join Date: May 2010
Posts: 19
Default 1982 Ezgo Gas not running sometimes.

I think i am having a spark issue. Sometimes i would push the petal and it fires right up. Sometimes it just cranks over and over. Sometimes it cranks over and over and over, flutter the petal and BANG. Like a gun whent off.

Also I thought about replacing the IGNITOR coil. Can not find one for a 1982. Only a Pulsar coil,mine does not have one. What the hell. It looks like a metal box with 2 mount holes. Has a plug witch plugs into the engine. And I think 3 wires also. Please help
brad1161 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-03-2010, 11:17 PM   #2
vzdude
Gone Wild
 
Join Date: May 2010
Location: NW Indiana
Posts: 283
Default Re: 1982 Ezgo Gas not running sometimes.

I would check the micro switch for the pedal.......did a search and saw a lot of issues with them being loose or broken.
vzdude is offline   Reply With Quote
Old 06-04-2010, 09:39 AM   #3
brad1161
Not Yet Wild
 
Join Date: May 2010
Posts: 19
Default Re: 1982 Ezgo Gas not running sometimes.

Its farely new. Correct me if im wrong if it was bad it would not crank over. Its cranks when you push the petal and the switch closes.

Does anyone know DOES A 1982 EZGO GAS HAVE A PULSAR COIL OR A IGNITOR COIL? MINE DOES NOT HAVE A PULSAR COIL.
brad1161 is offline   Reply With Quote
Old 06-04-2010, 08:38 PM   #4
ez go go
Doin' the Wild Thang
 
ez go go's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Greenville, AL
Posts: 1,063
Default Re: 1982 Ezgo Gas not running sometimes.

Your correct on the micro... Don't think vzdude was on track.... Not to quick on these two smokers but I will try seein as not much help has come your way.. If it is a spark issue I have read some posts about an HEI conv. on the coil that uses a GM coil to replace the factory setup. All the results have been positive in the performance aspect. I don't think it has an ignitor, however seein that you know your year model and make you can visit the tech section and download the manual to your cart and do a little homework while you wait on a response to help you with your problem.. Hope this was helpful and hang in ther someone with a little more two stroke knowledge will come shortly!!
ez go go is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
looking for a cab for my 1982 ezgo Gas EZGO
1982 ezgo gas Gas EZGO
1982 ezgo gas Gas EZGO
1982 EZGO - Got it running but have to run @ 1/2 choke. Ideas? Gas EZGO
1982 ezgo won't go Electric EZGO


All times are GMT -5. The time now is 07:35 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.