lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha
Gas Yamaha Gas Yamaha Golf Cars; G1 through "The Drive" and U-Max Utility Vehicles



Post New Thread  Reply
 
Thread Tools Display Modes
Old 04-07-2013, 09:37 PM   #1
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Hello, new G9 owner, need help...pics inside!

Hey guys, long time reader, first time poster.

I recently bought an ugly but running G9. After lots of reading I got a few things fixed, removed the body and finished the bodywork and paint. I have a long way to go but it's getting there, I was recently diagnosed with R.A. So the cart is basically just so I can take my kids up to the park and mess around. Anywho....

The thing that has me stumped is the valve cover ports. All of Mine are capped but one? The top port is connected to a hose that goes nowhere but is open. The bottom port is capped as is the passenger side port. The hose coming from the back of the engine near the exhaust goes direct to the fuel pump. The cart has no airbox and is running a K&N style air filter. The engine runs great, no smoke, pulls hard and runs smooth, I've driven it about 5 miles the last few days and had no issues, expect she backfires sometimes when getting on the throttle after stopping.

There is a small hose that comes from the bottom front passenger side of the motor that's capped, not sure where that's supposed to go?

If I connect everything correctly, minus the check valve as I don't have one and the plugged hose from the front passenger side of the motor as i dont know where that goes, the cart doesn't run. The only way to get it to run is to choke the hell out of it and event then it runs for a minute then dies.

Am I correct in assuming that running the way it is now is getting no oil to the top end?

If the current setup is not good, how do I get it to run when connected correctly?

Please help!

before and after pics to follow
Steelhammer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 04-07-2013, 09:41 PM   #2
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Before




After, I decided to go with a two tone blue and black metallic flake



Will get better pics tomorrow



Steelhammer is offline   Reply With Quote
Old 04-07-2013, 09:58 PM   #3
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,773
Default Re: Hello, new G9 owner, need help...pics inside!

Hammer, nice work on the body! Here are a couple pictures, hope they help! There are better pictures in the G8 club.
Attached Images
File Type: jpg IMAG0187.jpg (141.8 KB, 0 views)
File Type: jpg IMAG0186.jpg (202.2 KB, 0 views)
Mike Mac is offline   Reply With Quote
Old 04-07-2013, 10:27 PM   #4
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Thanks for the pics, I think I've seen them in other threads, and they did help.
My question, would running it the way it's now damage the engine? I am Assuming I'm not getting oil to the top end? Or is it ok the way it is?

If I hook the line from the back of the motor near the exhaust to the top of the valve cover port, hook the passenger side port to the fuel pump and run a breather on the port that should go to the air box the motor doesn't run without full choke, then dies after a minute or two.
Steelhammer is offline   Reply With Quote
Old 04-07-2013, 10:28 PM   #5
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Thanks for the compliments on the body work, didnt come out to shabby for rattle cans.
Steelhammer is offline   Reply With Quote
Old 04-08-2013, 07:06 AM   #6
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,773
Default Re: Hello, new G9 owner, need help...pics inside!

There is a port coming from the front, (down low). That is the port for vacuum, to run the fuel pump. But there needs to be a check valve (in that line), to draw oil from the port on the back of the motor, up to the port on the back of the valve cover. That line on the back of the motor, is oil supply to the rocker galley. That check valve is just above the little (white) twisty, in the first pic. (passenger side of the valve cover).

Search; "Stepper oil supply". Smallblock!!

It is imparative, that the air box be assembled correctly, and sealed from any air leaks. Except at the snorkel.
Mike Mac is offline   Reply With Quote
Old 04-08-2013, 08:18 AM   #7
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Ok, so I need to buy a tee and a check valve

I don't have an airbox, it has a k&n style filter on the end of the carb
Steelhammer is offline   Reply With Quote
Old 04-08-2013, 08:34 AM   #8
Mike Mac
G8 Specialist
Yamaha
 
Join Date: Jun 2009
Location: Phoenix
Posts: 7,773
Default Re: Hello, new G9 owner, need help...pics inside!

You need the T and the Yamaha check valve.

Your open element filter, will require jetting and reading the plug.
Mike Mac is offline   Reply With Quote
Old 04-08-2013, 09:32 AM   #9
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Anybody have a link to where I can buy the Yamaha check valve? google searches go nowhere and the Yamaha site doesn't allow me to navigate around on my iPad. I can use the Yamaha site to order if someone can link me directly to the part page I need, I just can't get from the home page to where I need to go.

Thank you again!
Steelhammer is offline   Reply With Quote
Old 04-08-2013, 10:06 AM   #10
Steelhammer
Not Yet Wild
 
Join Date: Mar 2013
Posts: 20
Default Re: Hello, new G9 owner, need help...pics inside!

Nevermind, found it!
Steelhammer is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas Yamaha


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ezgo electronics question PICS inside Electric EZGO
Concerns I have With My EZGO TXT Pics Inside Electric EZGO
1st 2003 series Electric Cart (pics inside) Electric EZGO
Looking to make my gasser street legal. Need electrical advise. Pics inside. HELP :) Gas EZGO
Usps Came Today! pics inside Lifted Golf Carts


All times are GMT -5. The time now is 10:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.