lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO
Gas EZGO Gas EZGO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-29-2016, 05:41 PM   #1
chuck3815
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2012
Location: seattle, wa
Posts: 44
Default 1974?

I am trying to get this golf cart to run. It ran before and now does not but will if I use starting fluid. I took it to a golf cart repair shop and he said that it was not the right carb. But I said then why did it run before? No comment his the bill. He said that the engine was not a Robbins. The tag on cart says gx440. Can anyone tell me what they thing the problem might be. Thanks so much
Attached Images
File Type: jpg IMG_0001.jpg (168.6 KB, 0 views)
File Type: jpg IMG_0002.jpg (243.0 KB, 0 views)
File Type: jpg IMG_0003.jpg (174.6 KB, 0 views)
chuck3815 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-29-2016, 07:31 PM   #2
meangreenmachine72
Gone Wild
Mixed Breed
 
Join Date: Apr 2011
Location: New Jersey
Posts: 999
Default Re: 1974?

If it ran before with that carb it sounds like a fuel issue. Lack of getting to carb, dirty filter and carb or cracked line and loosing prime. Check these items and make sure you have fresh gas.
meangreenmachine72 is offline   Reply With Quote
Old 01-02-2017, 09:46 PM   #3
TomStark
Gone Wild
 
TomStark's Avatar
E-Z-GO
 
Join Date: Jul 2015
Location: Metro Detroit
Posts: 449
Default Re: 1974?

I agree, right or wrong carb it should be able to run. start with the basics, make sure it has compression, and how much. (I see 120 written on it but who knows how long ago that was and if the guy doing it read the gauge right, or had a bad gauge, who knows. I never trust anything! LOL!) Also make sure it has spark. If it runs with starting fluid it should have compression and spark. Once you verify compression and steady spark (not intermittent spark) then I would pull the carb, and check for anything plugging it up. Clean it, reassemble it, and put good fuel in it and it should run (assuming spark and compression are good).
Tom
TomStark is offline   Reply With Quote
Old 01-02-2017, 11:23 PM   #4
meangreenmachine72
Gone Wild
Mixed Breed
 
Join Date: Apr 2011
Location: New Jersey
Posts: 999
Default Re: 1974?

I found a piece of electrical tape in my tank that was getting sucked up and clogging the fuel picku tube.
meangreenmachine72 is offline   Reply With Quote
Old 01-03-2017, 12:21 AM   #5
TomStark
Gone Wild
 
TomStark's Avatar
E-Z-GO
 
Join Date: Jul 2015
Location: Metro Detroit
Posts: 449
Default

Quote:
Originally Posted by meangreenmachine72 View Post
I found a piece of electrical tape in my tank that was getting sucked up and clogging the fuel picku tube.
Well that won't help it run at all! LOL. Did you get it started after the tape removal?
Tom

Sent from my SM-G900T using Tapatalk
TomStark is offline   Reply With Quote
Old 01-03-2017, 03:40 PM   #6
meangreenmachine72
Gone Wild
Mixed Breed
 
Join Date: Apr 2011
Location: New Jersey
Posts: 999
Default Re: 1974?

Yes it did run. My wife thought I was crazy buying another cart, I didn't tell her until I arrived home to unload it that it was buy one get one free. Lol. It was two Yamaha G1's.
meangreenmachine72 is offline   Reply With Quote
Old 01-03-2017, 07:41 PM   #7
LocoGary
Not Yet Wild
 
Join Date: Jul 2015
Posts: 9
Default

Sounds like carb issues, the red goo don't help.

GX engine usually means Honda
http://www.hondapartsnation.com/oemp...es_gx440/parts


Sent from my iPhone using Tapatalk
LocoGary is offline   Reply With Quote
Old 01-03-2017, 08:42 PM   #8
BrewCityMusic
Hammer Down !!!!
 
BrewCityMusic's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Lake Geneva, WI
Posts: 2,681
Default Re: 1974?

Quote:
Originally Posted by LocoGary View Post
Sounds like carb issues, the red goo don't help.

GX engine usually means Honda
http://www.hondapartsnation.com/oemp...es_gx440/parts


Sent from my iPhone using Tapatalk
EZGO Marathons carried the "GX" model numbers, GX440 was the 3-wheel Marathon, GX444 was the 4-wheel, IIRC
BrewCityMusic is offline   Reply With Quote
Old 01-15-2017, 05:38 PM   #9
chuck3815
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2012
Location: seattle, wa
Posts: 44
Default Re: 1974?

thanks for all replies. I checked the compression again and it indeed was 120.
Something I was wondering. Seeing how the gas tank is above the enging, does it need a fuel pump? It has one and I put new gaskets in, rubbers the whole thing in kit. But I use to race bikes and we never used fuel pumps because of tank above the engine.
I do think that I will take tank out and drain and wash out to be sure its clean.
Thanks for all your help and crossing my fingers.
chuck3815 is offline   Reply With Quote
Old 01-15-2017, 05:50 PM   #10
TomStark
Gone Wild
 
TomStark's Avatar
E-Z-GO
 
Join Date: Jul 2015
Location: Metro Detroit
Posts: 449
Default

Quote:
Originally Posted by chuck3815 View Post
thanks for all replies. I checked the compression again and it indeed was 120.
Something I was wondering. Seeing how the gas tank is above the enging, does it need a fuel pump? It has one and I put new gaskets in, rubbers the whole thing in kit. But I use to race bikes and we never used fuel pumps because of tank above the engine.
I do think that I will take tank out and drain and wash out to be sure its clean.
Thanks for all your help and crossing my fingers.
Yes you need a fuel oump, the tank is barely above the engine on a bike it is fully over the engine. Pulling the tank and cleaning it is a good idea, as is changing the fuel lines. When done, fill it with gas and leave the line affordable at the carb and just crank it enough to make it shoot out fuel. That way you know the pump is working and all is God up to the carb. Then plug it into the carb and I'd the carb is good, she should start!
Tom

Sent from my SM-G900T using Tapatalk
TomStark is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Gas EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1974 HD Solenoid Gas Harley Davidson
1974 harley Gas Harley Davidson
1974 Harley Harley Davidson
1974 EZGO gas Gas EZGO
1974 Ezgo Test Post


All times are GMT -5. The time now is 08:01 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. 2006-2017 Buggiesgonewild.com. All rights reserved.