lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-05-2021, 09:01 AM   #1
Nick G
Not Yet Wild
Star
 
Join Date: Jul 2021
Location: Wildwood New Jersey
Posts: 3
Default Star speedometer not registering MPH

2013 Star EV, the speedometer has power but will not register MPH. I reads 0 all the time. Could this be a defective speed sensor? Also there is a small 4 prong female plug protruding from under the dash board. Is this the 12 volt accessory plug?

Thank You for any replies
Nick G is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-25-2021, 08:00 AM   #2
anpgator
Getting Wild
 
Join Date: Jun 2018
Posts: 95
Default Re: Star speedometer not registering MPH

the prong plug under the dash is where you could plug in a Curtis controller handheld programmer. No speedo reading could be a speed sensor problem, or wiring problem in that circuit. What speeds are you reaching and is it consistent?
anpgator is offline   Reply With Quote
Old 04-23-2022, 05:40 AM   #3
Nick G
Not Yet Wild
Star
 
Join Date: Jul 2021
Location: Wildwood New Jersey
Posts: 3
Default Re: Star speedometer not registering MPH

I replaced the speed sensor still only about 8 MPH. The cart will just stop and will not move. If I keep trying, I can get it to move a short distance. Today I'm going to check the batteries for voltage drop. The speedometer stays on zero at any speed. Thank You for your time. Have a great day.
Nick G is offline   Reply With Quote
Old 11-19-2022, 09:01 AM   #4
hardhouseinc
Getting Wild
 
Join Date: May 2022
Posts: 78
Default Re: Star speedometer not registering MPH

I saw another post a guy had issues with the carts low speed and it was a relay
Walkaway relay maybe.....?
hardhouseinc is offline   Reply With Quote
Reply

Tags
accessory plug., speedometer
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric golf carts > Star and Fairplay


Thread Tools
Display Modes


Similar Threads
Thread Forum
Registering Cart to LSV in IL Electric EZGO
registering these things Electric golf carts
Registering as LSV Electric Club Car
registering your cart in new york state Gas Yamaha


All times are GMT -5. The time now is 11:48 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
This Website and forum is the property of Buggiesgonewild.com. No material may be taken or duplicated in part or full without prior written consent of the owners of buggiesgonewild.com. © 2006-2017 Buggiesgonewild.com. All rights reserved.